• Benjamin Neff's avatar
    Fix compatibility with Bundler 1.6 · 63fcc9c1
    Benjamin Neff authored
    Stop using `Bundler.settings.with`, because it will be removed from
    Bundler 1.6.
    
    Also, as described in #7653, we could use `Bundler.settings[:with]`, but
    that would be internal API again, so it probably breaks again in the
    future. That's why I added a `BundlerHelper` module to parse the
    required optional group from our config files, without the use of any
    internal Bundler API.
    
    Fixes #7653
    63fcc9c1
bundler_helper.rb 828 Bytes