Add additional requirements to Security Dashboard

Merged Fabio Busatto requested to merge add-additional-requirements-to-security-dashboard into master

Description

Add more requirements to Group Security Dashboard documentation.

  1. requires GitLab Runner 11.5 or above
  2. Auto DevOps is not compatible yet