Upgrade json-jwt to v1.11.0

Merged Stan Hu requested to merge sh-bump-json-jwt into master

This fixes CVE-2019-18848 and brings in a number of minor fixes: https://github.com/nov/json-jwt/compare/v1.9.4..v1.11.0

Closes https://gitlab.com/gitlab-org/gitlab/issues/39148

Testing

I verified that Google OpenID still works with this update.

Edited by 🤖 GitLab Bot 🤖