Gitlab helm charts fail to create on Minikube
Summary
When following the Helm Chart documentation, attempting to set up a Gitlab instance on Minikube (for testing) fails with: SchedulerPredicates failed due to PersistentVolumeClaim is not bound: "gitlab-gitlab-etc", which is unexpected. Back-off restarting failed container.
Issue https://gitlab.com/gitlab-org/gitlab-ce/issues/32749 suggests that it is normal, and will work eventually after the cloud provider has provisioned the disks. This doesn't apply to Minikube, and it doesn't work eventually.
Steps to reproduce
Here are the steps I took, with Minikube v0.19.0, Kubernetes v1.6.0, Helm v2.4.2 on MacOS. Docker-machine is using Virtualbox:
# values.yml
externalUrl: gitlab.dev
serviceType: NodePort
gitlabRootPassword: password123
ingress:
enabled: true
hosts:
- gitlab.dev
-
minikube start --disk-size 80g --cpus 4 --memory 4080 -
helm init -
helm repo add gitlab https://charts.gitlab.io -
helm init -
helm install --name gitlab -f values.yml --namespace=gitlab gitlab/gitlab
What is the current bug behavior?
The Gitlab container fails with SchedulerPredicates failed due to PersistentVolumeClaim is not bound: "gitlab-gitlab-etc", which is unexpected.
What is the expected correct behavior?
The Gitlab container should start

