Skip to content
Snippets Groups Projects
Commit fa480018 authored by Muhammad Moinur Rahman's avatar Muhammad Moinur Rahman
Browse files

databases/mysac: Remove expired port

2023-06-30 databases/mysac: Requires upstream EOL MySQL 5.6

Approved by:	portmgr (blanket)
parent a3e0d1a4
No related branches found
No related tags found
No related merge requests found
......@@ -7664,3 +7664,4 @@ databases/ateam_mysql_ldap_auth||2023-06-30|Has expired: Requires upstream EOL M
databases/mysqlwsrep56-server||2023-06-30|Has expired: Requires upstream EOL MySQL 5.6
databases/mysql56-server||2023-06-30|Has expired: Upstream support ended in February 2021
databases/mysql56-client||2023-06-30|Has expired: Upstream support ended in February 2021
databases/mysac||2023-06-30|Has expired: Requires upstream EOL MySQL 5.6
......@@ -201,7 +201,6 @@
SUBDIR += mroonga
SUBDIR += mtop
SUBDIR += mydumper
SUBDIR += mysac
SUBDIR += mysql++
SUBDIR += mysql-connector-c++
SUBDIR += mysql-connector-java
......
PORTNAME= mysac
PORTVERSION= 1.1.2
CATEGORIES= databases
MASTER_SITES= http://www.arpalert.org/src/ \
http://xz.cx/downloads/mysac/
MAINTAINER= jake@xz.cx
COMMENT= MySQL Simple Asynchronous Client
WWW= https://www.arpalert.org/mysac.html
LICENSE= LGPL3
DEPRECATED= Requires upstream EOL MySQL 5.6
EXPIRATION_DATE= 2023-06-30
USES= mysql
IGNORE_WITH_MYSQL= 57 80 101m 102m 103m 57p 57w
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -I${LOCALBASE}/lib
PLIST_FILES= lib/libmysac.so \
lib/libmysac.so.0 \
lib/libmysac-static.a \
include/mysac.h
pre-build:
${TOUCH} ${WRKSRC}/make.deps
do-install:
${INSTALL_LIB} ${WRKSRC}/libmysac.so ${STAGEDIR}${PREFIX}/lib
${LN} -sf libmysac.so ${STAGEDIR}${PREFIX}/lib/libmysac.so.0
${INSTALL_DATA} ${WRKSRC}/libmysac-static.a ${STAGEDIR}${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/mysac.h ${STAGEDIR}${PREFIX}/include
.include <bsd.port.mk>
SHA256 (mysac-1.1.2.tar.gz) = 0150edee0df888f9c6fe884c07281242ee28d408023994834facff93db15d77b
SIZE (mysac-1.1.2.tar.gz) = 45407
--- Makefile.orig 2012-01-02 06:39:03.451282135 +0000
+++ Makefile 2012-01-02 06:40:08.403362273 +0000
@@ -15,24 +15,26 @@
# You should have received a copy of the GNU General Public License
# along with MySAC. If not, see <http://www.gnu.org/licenses/>.
#
-SHELL=/bin/bash
+SHELL=/bin/sh
# Mysql lib directory
# exemple: <path>/mysql-5.1.41/libmysql_r/.libs
-MYSQL_LIB := /usr/lib
+MYSQL_LIB := $(LOCALBASE)/lib/mysql
# Mysql include directory
# exemple: <path>/mysql-5.1.41/include
-MYSQL_INC := /usr/include/mysql
+MYSQL_INC := $(LOCALBASE)/include/mysql
# get build version from the git tree in the form "lasttag-changes",
# and use "VERSION" file if unknown.
BUILDVER := $(shell ./mysac_ver)
-CFLAGS = -DBUILDVER=$(BUILDVER) -I$(MYSQL_INC) -O0 -g -Wall -Werror -fpic
-LDFLAGS = -g -L$(MYSQL_LIB) -lmysqlclient_r
+CFLAGS += -DBUILDVER=$(BUILDVER) -I$(MYSQL_INC) -O0 -g -Wall -fpic
+LDFLAGS += -g -L$(MYSQL_LIB) -lmysqlclient_r
OBJS = mysac.o mysac_net.o mysac_decode_field.o mysac_decode_row.o mysac_encode_values.o mysac_errors.o
+all: build
+
build: make.deps
$(MAKE) lib
--- mysac.c.orig 2012-01-02 05:39:13.267796448 +0000
+++ mysac.c 2012-01-02 05:39:23.079360664 +0000
@@ -22,8 +22,8 @@
#include <string.h>
#include <stdarg.h>
#include <ctype.h>
-#include <mysql/mysql.h>
#include <mysql/my_global.h>
+#include <mysql/mysql.h>
#include "mysac_decode_field.h"
#include "mysac_encode_values.h"
--- mysac_decode_field.c.orig 2011-06-06 20:58:33.000000000 +0100
+++ mysac_decode_field.c 2012-01-02 05:47:37.837388605 +0000
@@ -21,8 +21,8 @@
#include <stdint.h>
#include <string.h>
#include <stdarg.h>
-#include <mysql/mysql.h>
#include <mysql/my_global.h>
+#include <mysql/mysql.h>
#include "mysac_utils.h"
#include "mysac.h"
MySAC (Simple Asynchronous Client) is a library that provides mechanisms for
making asynchronous requests to MySQL database. It uses the official MySQL
client library for authentication and network functions. Memory allocation
must be done in user code, so any memory manager can be used.
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment