Skip to content
GitLab
Menu
Why GitLab
Pricing
Contact Sales
Explore
Why GitLab
Pricing
Contact Sales
Explore
Sign in
Get free trial
Primary navigation
Search or go to…
Project
F
FreeBSD ports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Privacy statement
Keyboard shortcuts
?
What's new
6
Snippets
Groups
Projects
Show more breadcrumbs
FreeBSD
FreeBSD ports
Commits
c4fd21d3
You need to sign in or sign up before continuing.
Commit
c4fd21d3
authored
5 months ago
by
Sergey A. Osokin
Browse files
Options
Downloads
Patches
Plain Diff
security/boringssl: update to the recent snapshot
parent
d27fdfcb
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
security/boringssl/Makefile
+2
-3
2 additions, 3 deletions
security/boringssl/Makefile
security/boringssl/distinfo
+3
-3
3 additions, 3 deletions
security/boringssl/distinfo
security/boringssl/files/patch-CMakeLists.txt
+2
-2
2 additions, 2 deletions
security/boringssl/files/patch-CMakeLists.txt
with
7 additions
and
8 deletions
security/boringssl/Makefile
+
2
−
3
View file @
c4fd21d3
PORTNAME
=
boringssl
PORTVERSION
=
0.0.0.0.2024.10.11.01
PORTREVISION
=
1
PORTVERSION
=
0.0.0.0.2024.10.26.01
CATEGORIES
=
security
EXTRACT_ONLY
=
${
GH_ACCOUNT
}
-
${
PORTNAME
}
-
${
PORTVERSION
}
-
${
GH_TAGNAME
}
_GH0.tar.gz
...
...
@@ -20,7 +19,7 @@ CPE_VENDOR= google
USE_GITHUB
=
yes
GH_ACCOUNT
=
google
GH_TAGNAME
=
d0b6ca2
GH_TAGNAME
=
b8c97f5
CMAKE_ARGS
+=
-DBUILD_SHARED_LIBS
=
1
CFLAGS_i386
=
-msse2
...
...
This diff is collapsed.
Click to expand it.
security/boringssl/distinfo
+
3
−
3
View file @
c4fd21d3
TIMESTAMP = 17
2868460
7
TIMESTAMP = 17
3006639
7
SHA256 (filippo.io/mlkem768/@v/v0.0.0-20240821141156-859a9b3f2ff6.zip) = 937bf0a147580a33e2a8831bc73edb8889698f9e906c71740ddf4fffb9691d4e
SIZE (filippo.io/mlkem768/@v/v0.0.0-20240821141156-859a9b3f2ff6.zip) = 21003
SHA256 (filippo.io/mlkem768/@v/v0.0.0-20240821141156-859a9b3f2ff6.mod) = e11c63e9fabc4f05d5f369a535d67287958b4f9266390b68882f28d67311a676
...
...
@@ -19,5 +19,5 @@ SHA256 (golang.org/x/term/@v/v0.23.0.zip) = 2597a62b487b952c11c89b2001551af1fe1d
SIZE (golang.org/x/term/@v/v0.23.0.zip) = 19866
SHA256 (golang.org/x/term/@v/v0.23.0.mod) = d44cfec368bf145eb7174b94307dbbf13d9ce881f03de797c3abf5731fba1eba
SIZE (golang.org/x/term/@v/v0.23.0.mod) = 68
SHA256 (google-boringssl-0.0.0.0.2024.10.
11
.01-
d0b6ca2
_GH0.tar.gz) =
4bd6966bdd3d4ac9847910be620b4c8f1f6bd4440314f6a030b42b199c251c7c
SIZE (google-boringssl-0.0.0.0.2024.10.
11
.01-
d0b6ca2
_GH0.tar.gz) = 45
420164
SHA256 (google-boringssl-0.0.0.0.2024.10.
26
.01-
b8c97f5
_GH0.tar.gz) =
0ee3f64681562a62961c8eb2119457b1d70cceb9b6fdcd6842ec079ebc227f0a
SIZE (google-boringssl-0.0.0.0.2024.10.
26
.01-
b8c97f5
_GH0.tar.gz) = 45
509412
This diff is collapsed.
Click to expand it.
security/boringssl/files/patch-CMakeLists.txt
+
2
−
2
View file @
c4fd21d3
--- CMakeLists.txt.orig 2024-0
9
-26
16
:4
1
:2
5
UTC
--- CMakeLists.txt.orig 2024-
1
0-26
00
:4
9
:2
1
UTC
+++ CMakeLists.txt
@@ -6
2
4,6 +6
2
4,8 @@ target_link_libraries(ssl crypto)
@@ -64
8
,6 +64
8
,8 @@ target_link_libraries(ssl crypto)
# here.
set_property(TARGET ssl PROPERTY EXPORT_NAME SSL)
target_link_libraries(ssl crypto)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment