Skip to content
Snippets Groups Projects
Commit 9fe3f64b authored by Rene Ladan's avatar Rene Ladan
Browse files

polish/kadu: Remove expired port:

2023-05-31 polish/kadu: Upstream website no longer exists, no update on SourceForge
parent 448bdaf5
No related branches found
No related tags found
No related merge requests found
Showing
with 1 addition and 5402 deletions
......@@ -7589,3 +7589,4 @@ multimedia/nordlicht||2023-05-31|Has expired: Unmaintained for years upstream an
finance/vanitygen||2023-05-31|Has expired: Broken for more than a year and upstream last release was 11 years ago
net-p2p/qtum||2023-05-31|Has expired: Broken for nearly a year
sysutils/pam_mount||2023-05-31|Has expired: Requires upstream EOL OpenSSL 1.0.X and linux only libmount which is not available for FreeBSD
polish/kadu||2023-05-31|Has expired: Upstream website no longer exists, no update on SourceForge
......@@ -5,7 +5,6 @@
SUBDIR += gnugadu2
SUBDIR += hunspell
SUBDIR += hyphen
SUBDIR += kadu
SUBDIR += libgadu
SUBDIR += libreoffice
SUBDIR += libtlen
......
PORTNAME= kadu
PORTVERSION= 4.3
PORTREVISION= 27
PORTEPOCH= 1
CATEGORIES= polish net-im
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/:kadu \
http://download.kadu.im/stable/:kadu \
http://download.kadu.im/additions/:additions
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:kadu
DIST_SUBDIR= kadu
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Internet communicator supporting Gadu-Gadu and Jabber/XMPP
WWW= http://kadu.im
BROKEN= Does not build against net-im/qxmpp-qt5
DEPRECATED= Upstream website no longer exists, no update on SourceForge
EXPIRATION_DATE= 2023-05-31
LICENSE= GPLv2
BUILD_DEPENDS= bash:shells/bash \
pl-libgadu>=1.12.2:polish/libgadu
LIB_DEPENDS= libmpdclient.so:audio/libmpdclient \
libsndfile.so:audio/libsndfile \
libinjeqt.so:devel/injeqt \
libidn.so:dns/libidn \
libQXmppQt5.so:net-im/qxmpp@qt5 \
libgadu.so:polish/libgadu \
libgcrypt.so:security/libgcrypt \
libotr.so.5:security/libotr \
libenchant.so:textproc/enchant
# TODO ntrack and ntrack-qt (needs porting) ?
# TODO separate ports for plugins and themes (possible starting with 0.10)
GG6_EMOTS_DISTFILE= kompatybilne_z_GG6.tar.gz
GG7_EMOTS_DISTFILE= dodatkowe_emoty_GG7.tar.gz
USES= cmake:insource compiler:c++17-lang cpe gettext-runtime gnome \
libarchive pkgconfig qca qt:5 readline tar:bzip2 xorg
USE_XORG= x11 xext xfixes xscrnsaver
USE_GNOME= glib20
USE_QT= concurrent core dbus declarative gui multimedia network \
script scripttools sql webkit widgets x11extras \
xml xmlpatterns \
buildtools:build linguisttools:build testlib:build \
qmake:build imageformats:run sql-sqlite3:run
# Setting KADU_VERSION disables git invocation
CMAKE_ARGS= -DKADU_VERSION:STRING="${DISTVERSION}" -DWITH_ENCHANT=ON \
-DENABLE_TESTS=OFF
LDFLAGS+= -lexecinfo
OPTIONS_DEFINE= GG_EMOTS
OPTIONS_SUB= yes
GG_EMOTS_DESC= GG-compatible emoticons
GG_EMOTS_DISTFILES= ${GG6_EMOTS_DISTFILE}:additions \
${GG7_EMOTS_DISTFILE}:additions
post-patch:
@${REINPLACE_CMD} '/kadu_add_test/ s|^|#|' \
${WRKSRC}/kadu-core/plugin/CMakeLists.txt
# ${FIND} ${WRKSRC} -type f -name '*.h' -o -name '*.cpp' | ${XARGS} ${REINPLACE_CMD} '/^#include/ s|qxmpp/|QXmppQt5/|g' \
post-install-GG_EMOTS-on:
@${MKDIR} ${WRKSRC}/varia/themes/emoticons
@cd ${WRKSRC}/varia/themes/emoticons && \
${TAR} -zxf ${_DISTDIR}/${GG6_EMOTS_DISTFILE} && \
${MV} kompatybilne_z_GG6 gg6_compatible && \
cd gg6_compatible && ${TAR} -zxf ${_DISTDIR}/${GG7_EMOTS_DISTFILE}
@cd ${WRKSRC}/varia/themes/emoticons && \
${COPYTREE_SHARE} gg6_compatible ${STAGEDIR}${DATADIR}/themes/emoticons
.include <bsd.port.mk>
TIMESTAMP = 1485469438
SHA256 (kadu/kadu-4.3.tar.bz2) = ad5d1cbb908c3cd07f2955d343d44b993cd5639427a48a2912441955cfd2bd6e
SIZE (kadu/kadu-4.3.tar.bz2) = 8087786
SHA256 (kadu/kompatybilne_z_GG6.tar.gz) = f8a84acd8512fd8fc38e394aa564e6b6d7ec2e9fe9864bdf0c5b8f2edb23da6f
SIZE (kadu/kompatybilne_z_GG6.tar.gz) = 254637
SHA256 (kadu/dodatkowe_emoty_GG7.tar.gz) = aebeb45b6ac9139620032436f7b565aa5729a0165d1c361a473c1195b8807450
SIZE (kadu/dodatkowe_emoty_GG7.tar.gz) = 113257
--- CMakeLists.txt.orig 2017-01-24 21:36:21 UTC
+++ CMakeLists.txt
@@ -25,7 +25,11 @@ if (NOT DEFINED CMAKE_CONFIGURATION_TYPES AND NOT CMAK
set (CMAKE_BUILD_TYPE "${default}" CACHE STRING "Choose the type of build, options are: None(CMAKE_CXX_FLAGS or CMAKE_C_FLAGS used) Debug Release RelWithDebInfo MinSizeRel." FORCE)
endif ()
-# C++14 support, warnings and other flags
+# C++17 support, warnings and other flags
+#
+# 17 is needed for std::optional, in qxmpp
+set (CMAKE_CXX_STANDARD 17)
+set (CMAKE_CXX_STANDARD_REQUIRED ON)
set (DEFINITIONS QT_NO_CAST_TO_ASCII QT_DISABLE_DEPRECATED_BEFORE=0x040900)
list (APPEND DEFINITIONS KADU_EXPORT_TESTS)
@@ -38,7 +42,6 @@ else ()
set (COMMON_COMPILE_FLAGS "-Wall -Wextra -Wundef -Wunused -Wuninitialized -Wcast-align -Wpointer-arith -fno-common")
set (C_FLAGS "-Wwrite-strings")
set (CXX_FLAGS "-Woverloaded-virtual -Wnon-virtual-dtor ${CXX_FLAGS}")
- set (CMAKE_CXX_STANDARD 14)
if (NOT WIN32)
set (COMMON_COMPILE_FLAGS "${COMMON_COMPILE_FLAGS} -fvisibility=hidden")
--- Plugins.cmake.orig 2016-10-16 20:09:16 UTC
+++ Plugins.cmake
@@ -106,12 +106,12 @@ if (UNIX AND NOT APPLE)
# docking
# Indicator docking support
# Comment if you are not compilign under Ubuntu flavor
- indicator_docking
+ #indicator_docking
# integration
# integration with Unity
# Comment if you are not compilign under Ubuntu flavor
- unity_integration
+ #unity_integration
# notifiers
# Freedesktop notification support
--- cmake/KaduMacros.cmake.orig 2021-04-03 20:24:23 UTC
+++ cmake/KaduMacros.cmake
@@ -44,7 +44,8 @@ include_directories (${INJEQT_INCLUDEDIR})
link_directories (${INJEQT_LIBRARY_DIRS})
set (CMAKE_CXX_FLAGS "-Woverloaded-virtual -Wnon-virtual-dtor ${CMAKE_CXX_FLAGS}")
-set (CMAKE_CXX_STANDARD 14)
+set (CMAKE_CXX_STANDARD 17)
+set (CMAKE_CXX_STANDARD_REQUIRED ON)
if (NOT WIN32)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")
--- kadu-core/CMakeLists.txt.orig 2019-03-30 14:44:31 UTC
+++ kadu-core/CMakeLists.txt
@@ -111,7 +111,7 @@ include_directories (${LibArchive_INCLUDE_DIRS})
list (APPEND ADDITIONAL_LIBKADU_LIBRARIES ${LibArchive_LIBRARIES})
if (UNIX AND NOT APPLE)
- find_package (X11 REQUIRED COMPONENTS X11 Xutil Xfixes)
+ find_package (X11 REQUIRED COMPONENTS Xutil Xfixes)
if (X11_FOUND AND X11_Xutil_FOUND AND X11_Xfixes_FOUND)
message (STATUS "Found required X11 libraries: ${X11_X11_LIB};${X11_Xfixes_LIB}")
else ()
--- kadu-core/execution-arguments/execution-arguments-parser.h.orig 2016-10-16 20:09:16 UTC
+++ kadu-core/execution-arguments/execution-arguments-parser.h
@@ -20,7 +20,7 @@
#pragma once
#include "exports.h"
-
+#include <cstdio>
#include <QtCore/QStringList>
class ExecutionArguments;
--- kadu-core/gui/actions/action-description.cpp.orig 2017-01-24 21:36:21 UTC
+++ kadu-core/gui/actions/action-description.cpp
@@ -103,7 +103,8 @@ void ActionDescription::registerAction(Actions *action
void ActionDescription::unregisterAction(Actions *actions)
{
- actions->remove(this);
+ if (actions)
+ actions->remove(this);
}
void ActionDescription::actionAboutToBeDestroyed(Action *action)
--- kadu-core/gui/widgets/avatar-painter.cpp.orig 2020-05-21 09:00:13 UTC
+++ kadu-core/gui/widgets/avatar-painter.cpp
@@ -22,6 +22,7 @@
#include <QtCore/QModelIndex>
#include <QtGui/QPainter>
+#include <QtGui/QPainterPath>
#include <QtGui/QPixmap>
#include <QtGui/QPixmapCache>
#include <QtWidgets/QStyleOptionViewItem>
--- kadu-core/gui/widgets/chat-widget/chat-widget-impl.cpp.orig 2016-10-19 17:23:42 UTC
+++ kadu-core/gui/widgets/chat-widget/chat-widget-impl.cpp
@@ -720,7 +720,7 @@ void ChatWidgetImpl::contactActivityChan
if (CurrentContactActivity == ChatState::Gone)
{
- auto msg = QString{"[ " + tr("%1 ended the conversation").arg(contact.ownerBuddy().display()) + " ]"};
+ auto msg = QString("[ " + tr("%1 ended the conversation").arg(contact.ownerBuddy().display()) + " ]");
Message message = m_messageStorage->create();
message.setMessageChat(CurrentChat);
message.setType(MessageTypeSystem);
--- kadu-core/plugin/dependency-graph/plugin-dependency-graph-builder.h.orig 2019-01-14 15:34:25 UTC
+++ kadu-core/plugin/dependency-graph/plugin-dependency-graph-builder.h
@@ -20,6 +20,7 @@
#pragma once
#include <QtCore/QObject>
+#include <functional>
#include <map>
#include <set>
--- kadu-core/themes.cpp.orig 2016-10-19 17:11:40 UTC
+++ kadu-core/themes.cpp
@@ -164,7 +164,7 @@ QStringList Themes::defaultPathsProvider
{
QStringList result;
- auto path = QString{m_pathsProvider->dataPath() + QStringLiteral("themes/") + Name};
+ auto path = QString(m_pathsProvider->dataPath() + QStringLiteral("themes/") + Name);
foreach(const QString &it, getSubDirs(path))
result << (path + '/' + it + '/');
--- plugins/idle/CMakeLists.txt.orig 2019-03-30 14:44:31 UTC
+++ plugins/idle/CMakeLists.txt
@@ -15,7 +15,7 @@ set (SOURCES
)
if (UNIX AND NOT APPLE)
- find_package (X11 REQUIRED COMPONENTS X11 Xutil Xscreensaver)
+ find_package (X11 REQUIRED COMPONENTS Xutil Xscreensaver)
if (X11_Xscreensaver_FOUND)
message (STATUS "Found required X11 libraries: ${X11_X11_LIB};${X11_Xscreensaver_LIB}")
else ()
--- plugins/pcspeaker/CMakeLists.txt.orig 2019-03-30 14:44:31 UTC
+++ plugins/pcspeaker/CMakeLists.txt
@@ -15,7 +15,7 @@ set (SOURCES
set (LIBRARIES "")
if (UNIX AND NOT APPLE)
- find_package (X11 REQUIRED COMPONENTS X11)
+ find_package (X11 REQUIRED)
if (NOT X11_FOUND)
message (SEND_ERROR "Could NOT find X11")
endif ()
--- plugins/screenshot/CMakeLists.txt.orig 2019-03-30 14:44:31 UTC
+++ plugins/screenshot/CMakeLists.txt
@@ -30,7 +30,7 @@ set (CONFIGURATION_FILES
if (UNIX AND NOT APPLE)
set (PLUGIN_ADDITIONAL_QT_MODULES X11Extras)
- find_package (X11 REQUIRED COMPONENTS X11 Xext Xshape)
+ find_package (X11 REQUIRED COMPONENTS Xext Xshape)
if (X11_Xshape_FOUND)
message (STATUS "Found required X11 libraries: ${X11_X11_LIB};${X11_Xext_LIB}")
else ()
Qt based internet communicator supporting Gadu-Gadu and Jabber/XMPP
protocols for Unix-like and Windows systems.
Gadu-Gadu is an ICQ-like messenger for polish language users.
Source diff could not be displayed: it is too large. Options to address this: view the blob.
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment