Skip to content
Snippets Groups Projects
Commit 2c3725f5 authored by Dustin Marquess's avatar Dustin Marquess Committed by Beat Gaetzi
Browse files

www/elinks: Update to 0.15.0

Pass maintainership to submitter

PR:	261189
parent cc230705
No related branches found
No related tags found
No related merge requests found
# Created by: Michael Vasilenko <acid@stu.cn.ua>
PORTNAME= elinks
DISTVERSION= 0.11.7
PORTREVISION= 13
DISTVERSIONPREFIX= v
DISTVERSION= 0.15.0
CATEGORIES= www
MASTER_SITES= http://elinks.or.cz/download/
MAINTAINER= beat@FreeBSD.org
MAINTAINER= jailbird@fdf.net
COMMENT= Links text WWW browser with enhancements
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
USES= bison:alias cpe gmake localbase ssl tar:bzip2
USES= autoreconf bison:alias cpe gmake localbase ssl
CONFIGURE_ARGS= --without-zlib
USE_GITHUB= yes
GH_ACCOUNT= rkd77
LIBS+= -lexecinfo
OPTIONS_DEFINE= 88COLORS 256COLORS SPIDERMONKEY XBELMARKS LOCAL_CGI \
......
SHA256 (elinks-0.11.7.tar.bz2) = 456db6f704c591b1298b0cd80105f459ff8a1fc07a0ec1156a36c4da6f898979
SIZE (elinks-0.11.7.tar.bz2) = 2467915
TIMESTAMP = 1644995066
SHA256 (rkd77-elinks-v0.15.0_GH0.tar.gz) = 49e261fb7a6b061b51ca38b7152712caba90c8eaa6996bcf4c00fe2867a7f366
SIZE (rkd77-elinks-v0.15.0_GH0.tar.gz) = 3783388
--- configure.ac.orig 2022-01-29 19:43:50 UTC
+++ configure.ac
@@ -1861,7 +1861,7 @@ if test "x$ac_cv_c_compiler_gnu" = "xyes"; then
;;
10|10.*|11|11.*)
# gettext
- CFLAGS="$CFLAGS -fno-strict-aliasing -Wno-builtin-declaration-mismatch -Wno-array-bounds"
+ CFLAGS="$CFLAGS -fno-strict-aliasing -Wno-array-bounds"
;;
*)
# These should be ok using -Werror
--- src/intl/gettext/Makefile.orig Thu Feb 16 07:41:10 2006
+++ src/intl/gettext/Makefile Thu Feb 16 07:48:45 2006
@@ -47,14 +47,12 @@
--- src/intl/gettext/Makefile.orig 2021-12-24 19:53:43 UTC
+++ src/intl/gettext/Makefile
@@ -49,14 +49,12 @@ install-local: $(builddir)/charset.alias all
if test -f $(DESTDIR)$(libdir)/charset.alias; then \
orig=$(DESTDIR)$(libdir)/charset.alias; \
sed -f ref-add.sed $$orig > $$temp; \
......@@ -15,7 +15,7 @@
rm -f $$temp; \
fi; \
fi; \
@@ -65,7 +63,6 @@
@@ -67,7 +65,6 @@ install-local: $(builddir)/charset.alias all
temp=$(DESTDIR)$(localedir)/t-locale.alias; \
dest=$(DESTDIR)$(localedir)/locale.alias; \
sed -f ref-add.sed $$orig > $$temp; \
......
--- src/network/ssl/socket.c.orig 2017-02-08 12:49:43 UTC
+++ src/network/ssl/socket.c
@@ -67,7 +67,7 @@ static void
ssl_set_no_tls(struct socket *socket)
{
#ifdef CONFIG_OPENSSL
- ((ssl_t *) socket->ssl)->options |= SSL_OP_NO_TLSv1;
+ SSL_set_options((ssl_t *) socket->ssl, SSL_OP_NO_TLSv1);
#elif defined(CONFIG_GNUTLS)
{
/* GnuTLS does not support SSLv2 because it is "insecure".
@@ -145,7 +145,7 @@
}
if (client_cert) {
- SSL_CTX *ctx = ((SSL *) socket->ssl)->ctx;
+ SSL_CTX *ctx = SSL_get_SSL_CTX(socket->ssl);
SSL_CTX_use_certificate_chain_file(ctx, client_cert);
SSL_CTX_use_PrivateKey_file(ctx, client_cert,
--- src/network/ssl/ssl.c.orig 2019-01-09 23:04:06 UTC
+++ src/network/ssl/ssl.c
@@ -49,11 +49,17 @@ init_openssl(struct module *module)
* cannot initialize the PRNG and so every attempt to use SSL fails.
* It's actually an OpenSSL FAQ, and according to them, it's up to the
* application coders to seed the RNG. -- William Yodlowsky */
- if (RAND_egd(RAND_file_name(f_randfile, sizeof(f_randfile))) < 0) {
+ RAND_file_name(f_randfile, sizeof(f_randfile));
+#ifndef OPENSSL_NO_EGD
+ if (RAND_egd(f_randfile) < 0)
+ {
/* Not an EGD, so read and write to it */
+#endif
if (RAND_load_file(f_randfile, -1))
RAND_write_file(f_randfile);
+#ifndef OPENSSL_NO_EGD
}
+#endif
SSLeay_add_ssl_algorithms();
context = SSL_CTX_new(SSLv23_client_method());
--- src/osdep/unix/bsd.c.orig 2022-01-29 20:03:00 UTC
+++ src/osdep/unix/bsd.c
@@ -15,6 +15,10 @@
#endif /* HAVE_SYS_CONSIO_H */
#endif /* CONFIG_SYSMOUSE */
+#if defined(__FreeBSD__)
+#include <signal.h>
+#endif
+
#include "elinks.h"
#include "main/select.h"
--- src/scripting/lua/Makefile.orig 2007-07-30 16:17:41.000000000 +0200
+++ src/scripting/lua/Makefile 2007-07-30 16:17:53.000000000 +0200
--- src/scripting/lua/Makefile.orig 2021-12-24 19:53:43 UTC
+++ src/scripting/lua/Makefile
@@ -1,7 +1,7 @@
top_builddir=../../..
include $(top_builddir)/Makefile.config
......
......@@ -18,4 +18,4 @@ So far elinks adds the following to links:
Spidermonkey-based ECMAScript support
Syntax highlighting for HTML, RSS, and XBEL
WWW: http://elinks.or.cz/
WWW: https://github.com/rkd77/elinks/
......@@ -2,6 +2,7 @@ bin/elinks
man/man1/elinks.1.gz
man/man5/elinkskeys.5.gz
man/man5/elinks.conf.5.gz
%%NLS%%share/locale/af/LC_MESSAGES/elinks.mo
%%NLS%%share/locale/be/LC_MESSAGES/elinks.mo
%%NLS%%share/locale/bg/LC_MESSAGES/elinks.mo
%%NLS%%share/locale/ca/LC_MESSAGES/elinks.mo
......@@ -19,6 +20,7 @@ man/man5/elinks.conf.5.gz
%%NLS%%share/locale/id/LC_MESSAGES/elinks.mo
%%NLS%%share/locale/is/LC_MESSAGES/elinks.mo
%%NLS%%share/locale/it/LC_MESSAGES/elinks.mo
%%NLS%%share/locale/ja/LC_MESSAGES/elinks.mo
%%NLS%%share/locale/lt/LC_MESSAGES/elinks.mo
%%NLS%%share/locale/nb/LC_MESSAGES/elinks.mo
%%NLS%%share/locale/nl/LC_MESSAGES/elinks.mo
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment