Skip to content
Snippets Groups Projects
Commit 25593399 authored by sunpoet's avatar sunpoet
Browse files

- Update to 0.3.4

parent 09495a42
Branches
Tags
No related merge requests found
......@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= glog
PORTVERSION= 0.3.3
PORTREVISION= 3
PORTVERSION= 0.3.4
CATEGORIES= devel
MASTER_SITES= GOOGLE_CODE
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Library of C++ classes for flexible logging
......@@ -22,10 +20,14 @@ INSTALL_TARGET= install-strip
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
USE_LDCONFIG= yes
USES= execinfo libtool pathfix
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= *
PROJECTHOST= google-glog
GH_ACCOUNT= google
GH_PROJECT= ${PORTNAME}
GH_TAGNAME= v${PORTVERSION}
USE_GITHUB= yes
post-patch:
@${REINPLACE_CMD} -e '/^docdir = / s| = .*| = ${DOCSDIR}|' ${WRKSRC}/Makefile.in
......
SHA256 (glog-0.3.3.tar.gz) = fbf90c2285ba0561db7a40f8a4eefb9aa963e7d399bd450363e959929fe849d0
SIZE (glog-0.3.3.tar.gz) = 509676
SHA256 (google-glog-0.3.4-v0.3.4_GH0.tar.gz) = ce99d58dce74458f7656a68935d7a0c048fa7b4626566a71b7f4e545920ceb10
SIZE (google-glog-0.3.4-v0.3.4_GH0.tar.gz) = 522508
--- src/glog/stl_logging.h.in.orig 2013-01-09 21:57:36.000000000 +0800
+++ src/glog/stl_logging.h.in 2013-09-20 19:39:39.000000000 +0800
@@ -53,8 +53,12 @@
#ifdef __GNUC__
# include <ext/hash_set>
# include <ext/hash_map>
+#ifdef _LIBCPP_VERSION
+# include <forward_list>
+#else
--- src/glog/stl_logging.h.in.orig 2015-03-11 12:02:27.000000000 +0800
+++ src/glog/stl_logging.h.in 2015-03-22 01:13:41.132580961 +0800
@@ -76,6 +76,9 @@
#ifdef GLOG_STL_LOGGING_FOR_EXT_SLIST
# include <ext/slist>
#endif
+#ifdef GLOG_STL_LOGGING_FOR_FORWARD_LIST
+# include <forward_list>
+#endif
// Forward declare these two, and define them after all the container streams
// operators so that we can recurse from pair -> container -> container -> pair
@@ -81,8 +85,12 @@ OUTPUT_TWO_ARG_CONTAINER(std::vector)
@@ -101,9 +104,13 @@
OUTPUT_TWO_ARG_CONTAINER(std::vector)
OUTPUT_TWO_ARG_CONTAINER(std::deque)
OUTPUT_TWO_ARG_CONTAINER(std::list)
#ifdef __GNUC__
+#ifdef _LIBCPP_VERSION
+OUTPUT_TWO_ARG_CONTAINER(std::forward_list)
+#else
+
#ifdef GLOG_STL_LOGGING_FOR_EXT_SLIST
OUTPUT_TWO_ARG_CONTAINER(__gnu_cxx::slist)
#endif
+#ifdef GLOG_STL_LOGGING_FOR_FORWARD_LIST
+OUTPUT_TWO_ARG_CONTAINER(std::forward_list)
+#endif
#undef OUTPUT_TWO_ARG_CONTAINER
......
--- src/googletest.h.orig 2015-03-11 12:02:27.000000000 +0800
+++ src/googletest.h 2015-03-22 00:56:38.711647313 +0800
@@ -58,6 +58,7 @@
#include "base/commandlineflags.h"
+using namespace gflags;
using std::map;
using std::string;
using std::vector;
--- src/logging_unittest.cc.orig 2015-03-11 12:02:27.000000000 +0800
+++ src/logging_unittest.cc 2015-03-22 00:54:39.798664493 +0800
@@ -78,6 +78,7 @@
#endif
using namespace std;
+using namespace gflags;
using namespace GOOGLE_NAMESPACE;
// Some non-advertised functions that we want to test or use.
--- src/stl_logging_unittest.cc.orig 2015-03-11 12:02:27.000000000 +0800
+++ src/stl_logging_unittest.cc 2015-03-22 01:03:23.871621079 +0800
@@ -41,6 +41,7 @@
// C++0x isn't enabled by default in GCC and libc++ does not have
// non-standard ext/* and tr1/unordered_*.
# if defined(_LIBCPP_VERSION)
+# define GLOG_STL_LOGGING_FOR_FORWARD_LIST
# define GLOG_STL_LOGGING_FOR_UNORDERED
# else
# define GLOG_STL_LOGGING_FOR_EXT_HASH
......@@ -3,4 +3,4 @@ The glog library implements application-level logging.
This library provides logging APIs based on C++-style streams
and various helper macros.
WWW: http://code.google.com/p/google-glog/
WWW: https://github.com/google/glog
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment