Skip to content

Skip buggy `requests` versions and resolve "certificate verify failed: self-signed certificate in certificate chain" error

Skip buggy requests versions and resolve "certificate verify failed: self-signed certificate in certificate chain" error

requests versions 2.32.0 to 2.32.3 (included) are affected by a bug breaking the ability to specify custom SSLContexts in sub-classes of HTTPAdapter (https://github.com/psf/requests/issues/6715) and another breaking the ability to load certificates with HTTPAdapters (https://github.com/psf/requests/issues/6730)

We skip those versions (and hope that 2.32.4 will provide a fix for https://github.com/psf/requests/issues/6730)

Cf #706

Closes #706

Merge request reports