no longer depend on `qubes-core-agent` / `qubes-gui-agent`

qubes-vm-dependencies already `Depends`: on it

https://github.com/QubesOS/qubes-builder-debian/blob/master/template_debian/packages_qubes.list

in preparation of
- removal of dependency on `qubes-core-agent-passwordless-root`
- support of VM sudo

https://www.qubes-os.org/doc/vm-sudo/
parent f392f406
......@@ -15,7 +15,6 @@ Standards-Version: 4.3.0
Package: qubes-whonix
Architecture: all
Depends: adduser,
qubes-core-agent,
qubesdb-vm,
ethtool,
net-tools,
......@@ -24,7 +23,7 @@ Depends: adduser,
rsync,
whonix-firewall,
curl,
qubes-core-agent (<< 4.0.0-1) | qubes-core-agent-networking,
qubes-core-agent-networking,
python3,
python3-pyqt5,
${misc:Depends}
......@@ -42,7 +41,7 @@ Description: Qubes Configuration for Whonix-Gateway and Whonix-Workstation
Package: qubes-whonix-shared-packages-recommended
Architecture: all
Depends: qubes-core-agent (<< 4.0.0-1) | qubes-core-agent-passwordless-root,
Depends: qubes-core-agent-passwordless-root,
qubes-kernel-vm-support, initramfs-tools, qubes-mgmt-salt-vm-connector,
qubes-usb-proxy, qubes-input-proxy-sender,
qubes-core-agent-thunar, qubes-core-agent-nautilus,
......@@ -58,7 +57,7 @@ Architecture: all
Depends: tinyproxy,
yum,
yum-utils,
qubes-core-agent (<< 4.0.0-1) | qubes-core-agent-dom0-updates,
qubes-core-agent-dom0-updates,
${misc:Depends}
Description: Recommended packages for Qubes-Whonix-Gateway
A metapackage, which installs packages, which are recommended for
......@@ -72,7 +71,7 @@ Depends: qubes-thunderbird,
qubes-gpg-split,
qubes-pdf-converter,
qubes-img-converter,
pulseaudio-qubes | qubes-gui-agent (<< 4.0.0),
pulseaudio-qubes,
${misc:Depends}
Description: Recommended packages for Qubes-Whonix-Workstation
A metapackage, which installs packages, which are recommended for
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment