Commit b1fd54e1 authored by Sébastien Helleu's avatar Sébastien Helleu

Update version 0.2.7 to 0.3.0 in scripts

parent d1488a5b
......@@ -22,7 +22,7 @@
# 0.2: now you don't need the Song Change plugin enabled because
# it uses audtool --current-song to get the music name as nenolod
# suggested (http://boards.nenolod.net/index.php?showtopic=147). :)
# 0.3: port to WeeChat 0.2.7 by Trashlord
# 0.3: port to WeeChat 0.3.0 by Trashlord
#
weechat::register ("audacious", "DeltaS4", "0.3", "GPL", "audacious-weechat current song script (usage: /music)", "", "");
......
......@@ -24,7 +24,7 @@
# 2009-05-02, FlashCode <flashcode@flashtux.org>:
# version 0.6, sync with last API changes
# 2008-11-30, GolemJ <golemj@gmail.com>:
# version 0.5, conversion to WeeChat 0.2.7+
# version 0.5, conversion to WeeChat 0.3.0+
#
###############################################################################
......
......@@ -22,7 +22,7 @@
# 2009-05-02, FlashCode <flashcode@flashtux.org>:
# version 0.4: sync with last API changes
# 2008-11-05, FlashCode <flashcode@flashtux.org>:
# version 0.3: conversion to WeeChat 0.2.7+
# version 0.3: conversion to WeeChat 0.3.0+
# 2007-08-10, FlashCode <flashcode@flashtux.org>:
# version 0.2: upgraded licence to GPL 3
# 2006-09-02, FlashCode <flashcode@flashtux.org>:
......
......@@ -3,7 +3,7 @@
#
# Original WeeChat Author: Julien Louis <ptitlouis@sysif.net>
#
# Port to WeeChat 0.2.7: Sid Vicious (aka Trashlord) <dornenreich666@gmail.com>
# Port to WeeChat 0.3.0: Sid Vicious (aka Trashlord) <dornenreich666@gmail.com>
weechat::register("fortune", "ptitlouis", "0.2", "Public domain", "Send a random fortune cookie to a specified nick", "", "");
......
......@@ -28,7 +28,7 @@
# version 0.4, version upgrade, minor cleanup of source
#
# 2009-04-18, kinabalu <andrew AT mysticcoders DOT com>
# version 0.3, version upgraded to support weechat 0.2.7+
# version 0.3, version upgraded to support weechat 0.3.0+
#
# 2009-04-16, kinabalu <andrew AT mysticcoders DOT com>
# version 0.2, removed need for Parse::IRC
......@@ -83,7 +83,7 @@ sub message_process_init {
}
#
# 0.2.7 clean version of highlighting for private messages
# 0.3.0 clean version of highlighting for private messages
#
sub highlight_privmsg {
my ( $nick, $message ) = ( $_[2] =~ /(.*?)\t(.*)/ );
......@@ -93,7 +93,7 @@ sub highlight_privmsg {
}
#
# 0.2.7 clean version of highlighting for public messages
# 0.3.0 clean version of highlighting for public messages
#
sub highlight_public {
my ( $data, $bufferp, undef, undef, undef, $ishilight, $nick, $message ) = @_;
......
# This is a rewrite of the script "Kernel" for WeeChat.
# This script is for WeeChat 0.2.7
# This script is for WeeChat 0.3.0
# Written by Julien Louis <ptitlouis@sysif.net>
# Port to WeeChat 0.2.7: Sid Vicious (aka Trashlord) <dornenreich666@gmail.com>
# Port to WeeChat 0.3.0: Sid Vicious (aka Trashlord) <dornenreich666@gmail.com>
# This script is public domain
use warnings;
......
......@@ -17,7 +17,7 @@
#
# Launch external commands for signals.
# (this script requires WeeChat 0.2.7 or newer)
# (this script requires WeeChat 0.3.0 or newer)
#
# History:
#
......
......@@ -17,14 +17,14 @@
#
# Play a sound for IRC "CTCP SOUND" message.
# (this script requires WeeChat 0.2.7 or newer)
# (this script requires WeeChat 0.3.0 or newer)
#
# History:
#
# 2009-05-02, FlashCode <flashcode@flashtux.org>:
# version 0.7: sync with last API changes
# 2009-02-03, FlashCode <flashcode@flashtux.org>:
# version 0.6: conversion to WeeChat 0.2.7+
# version 0.6: conversion to WeeChat 0.3.0+
# move commands for highlight and pv to new script launcher.pl
# 2007-09-17, FlashCode <flashcode@flashtux.org>:
# version 0.5: fixed security problem with message parsing and execution
......
......@@ -6,9 +6,9 @@
# Description : encrypt/decrypt PRIVMSGs in WeeChat using
# a pre-shared key and openssl
#
# *this version is for the upcoming weechat-0.2.7 only*
# *this version is for the upcoming weechat-0.3.0 only*
#
version="1.2-0.2.7"
version="1.3"
#
# This plugin uses openssl to encrypt/decrypt messages you send
# or receive with weechat. Due to the very simple method
......
"""
:Author: Henning Hasemann <hhasemann [at] web [dot] de>
30-01-2009 -- Adapted for Weechat 0.2.7 By Bonzodog
30-01-2009 -- Adapted for Weechat 0.3.0 By Bonzodog
(bonzodog01 [at] gmail [dot] com)
:What it does:
......
# Author: lavaramano <lavaramano AT gmail DOT com>
# Improved by: BaSh - <bash.lnx AT gmail DOT com>
# Ported to Weechat 0.2.7 by: Sharn - <sharntehnub AT gmail DOT com)
# Ported to Weechat 0.3.0 by: Sharn - <sharntehnub AT gmail DOT com)
# This Plugin Calls the libnotify bindings via python when somebody says your nickname, sends you a query, etc.
# To make it work, you may need to download: python-notify (and libnotify - libgtk)
# Requires Weechat 0.2.7
# Requires Weechat 0.3.0
# Released under GNU GPL v2
#
# 2009-05-02, FlashCode <flashcode@flashtux.org>:
......
#!/usr/bin/python
# pagetitle plugin for weechat-0.2.7
# pagetitle plugin for weechat-0.3.0
#
# /pt http://tech.slashdot.org/tech/08/11/12/199215.shtml
# <user> http://tech.slashdot.org/tech/08/11/12/199215.shtml
......
......@@ -5,7 +5,7 @@
# Licence : GPL v2
# Description : running shell commands in WeeChat
# Syntax : try /help shell to get some help on this script
# Precond : needs weechat >= 0.2.7 to run
# Precond : needs weechat >= 0.3.0 to run
#
#
# ### changelog ###
......@@ -17,7 +17,7 @@
# - add option -t <timeout> to kill process after <timeout> seconds
# - show process running, kill it with -kill
# * version 0.2, 2009-01-31, FlashCode <flashcode@flashtux.org>:
# - conversion to WeeChat 0.2.7+
# - conversion to WeeChat 0.3.0+
# * version 0.1, 2006-03-13, Kolter <kolter@openics.org> :
# - first release
#
......
#!/bin/env python
#
# TinyUrl, version 3.7, for weechat version 0.2.7 or later
# TinyUrl, version 3.7, for weechat version 0.3.0 or later
#
# Listens to all channels for long URLs, and submits them to ln-s.net or
# tinyurl.com for easier links.
......@@ -53,7 +53,7 @@
#
# Requirements:
#
# - Designed to run with weechat version 0.2.7 or better.
# - Designed to run with weechat version 0.3.0 or better.
# http://weechat.flashtux.org/
#
# - Requires that 'curl' is in the path (tested with curl 7.15.0).
......@@ -83,7 +83,7 @@
# by FlashCode <flashcode@flashtux.org>
#
# Version 3.6, 12 March, 2009
# Conversion to WeeChat 0.2.7+
# Conversion to WeeChat 0.3.0+
# by FlashCode <flashcode@flashtux.org>
#
# Version 3.5d, 19 September, 2008
......@@ -99,7 +99,7 @@
# by Chris Hills <chaz@chaz6.com>
#
# Version 3.5a, 18 July, 2008
# Updated for the new script api in weechat 0.2.7-dev
# Updated for the new script api in weechat 0.3.0-dev
# by Chris Hills <chaz@chaz6.com>
# Updated to use the tinyurl api instead of screen-scraping
# by Chris Hills <chaz@chaz6.com>
......
......@@ -18,7 +18,7 @@
#
# Display content of viedemerde.fr/fmylife.com website.
# (this script requires WeeChat 0.2.7 or newer)
# (this script requires WeeChat 0.3.0 or newer)
#
# History:
#
......
......@@ -18,7 +18,7 @@
#
# WeeChat scripts manager.
# (this script requires WeeChat 0.2.7 (or newer) and python 2.5)
# (this script requires WeeChat 0.3.0 (or newer) and python 2.5)
#
# History:
#
......@@ -409,7 +409,7 @@ def wg_show_script(name):
URL: http://weechat.flashtux.org/dev/scripts/weeget.py
Desc: Scripts manager.
Tags: scripts
Min: 0.2.7
Min: 0.3.0
"""
if len(wg_scripts) == 0:
return
......@@ -678,7 +678,7 @@ def wg_parse_xml():
'desc_en' : 'Scripts manager.',
'desc_fr' : 'Gestionnaire de scripts.',
'requirements': 'python 2.5',
'min_weechat' : '0.2.7',
'min_weechat' : '0.3.0',
'max_weechat' : '',
'author' : 'FlashCode',
'mail' : 'flashcode [at] flashtux [dot] org',
......
......@@ -18,7 +18,7 @@
#
# Send "whois" on nick when receiving new IRC query.
# (this script requires WeeChat 0.2.7 or newer)
# (this script requires WeeChat 0.3.0 or newer)
#
# History:
#
......
......@@ -29,7 +29,7 @@
# 2009-05-02, FlashCode <flashcode@flashtux.org>:
# version 1.2: sync with last API changes
# 2008-11-11, FlashCode <flashcode@flashtux.org>:
# version 1.1: conversion to WeeChat 0.2.7+
# version 1.1: conversion to WeeChat 0.3.0+
require 'net/http'
require 'uri'
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment