Commit 5c70d8c9 authored by Deimos's avatar Deimos

Update pypi package versions (requirements.txt)

I temporarily pinned two packages that will require more significant
updates (webargs in requirements and prospector in requirements-dev).
Other than those, everything seemed to upgrade cleanly, except for an
issue with mypy that needed a "type: ignore" comment to circumvent.

Note that there is currently an issue with Salt's pip module being
unable to handle comments in a requirements file that include "-r", so I
had to manually edit the two .txt files after using pip-tools to remove
all lines with "via -r" comments in them. I've commented about this in
an issue on Salt's repo here:
https://github.com/saltstack/salt/issues/56514#issuecomment-665947887
parent 25656152
......@@ -2,7 +2,7 @@
black
freezegun
mypy
prospector
prospector==1.2.0
pyramid-debugtoolbar
pytest
pytest-mock
......
ago==0.0.93
alembic==1.3.3
appdirs==1.4.3 # via black
argon2-cffi==19.2.0
alembic==1.4.2
appdirs==1.4.4 # via black
argon2-cffi==20.1.0
astroid==2.3.3 # via prospector, pylint, pylint-celery, pylint-flask, requirements-detector
attrs==19.3.0 # via black, pytest
backcall==0.1.0 # via ipython
beautifulsoup4==4.8.2
backcall==0.2.0 # via ipython
beautifulsoup4==4.9.1
black==19.10b0
bleach==3.1.0
certifi==2019.11.28 # via requests, sentry-sdk
cffi==1.13.2 # via argon2-cffi, pygit2
bleach==3.1.5
cached-property==1.5.1 # via pygit2
certifi==2020.6.20 # via requests, sentry-sdk
cffi==1.14.1 # via argon2-cffi, pygit2
chardet==3.0.4 # via requests
click==7.0
cornice==4.0.1
decorator==4.4.1 # via ipython, traitlets
click==7.1.2
cornice==5.0.1
decorator==4.4.2 # via ipython, traitlets
dodgy==0.2.1 # via prospector
freezegun==0.3.14
freezegun==0.3.15
gunicorn==20.0.4
html5lib==1.0.1
hupper==1.9.1 # via pyramid
idna==2.8 # via requests
html5lib==1.1
hupper==1.10.2 # via pyramid
idna==2.10 # via requests
iniconfig==1.0.0 # via pytest
ipython-genutils==0.2.0 # via traitlets
ipython==7.12.0
ipython==7.16.1
isort==4.3.21 # via pylint
jedi==0.16.0 # via ipython
jinja2==2.11.1 # via pyramid-jinja2
jedi==0.17.2 # via ipython
jinja2==2.11.2 # via pyramid-jinja2
lazy-object-proxy==1.4.3 # via astroid
mako==1.1.1 # via alembic, pyramid-mako
mako==1.1.3 # via alembic, pyramid-mako
markupsafe==1.1.1 # via jinja2, mako, pyramid-jinja2
marshmallow==3.4.0
marshmallow==3.7.1
mccabe==0.6.1 # via prospector, pylint
more-itertools==8.2.0 # via pytest
more-itertools==8.4.0 # via pytest
mypy-extensions==0.4.3 # via mypy
mypy==0.761
packaging==20.1 # via pytest
parso==0.6.1 # via jedi
mypy==0.782
packaging==20.4 # via bleach, pytest
parso==0.7.1 # via jedi
pastedeploy==2.1.0 # via plaster-pastedeploy
pathspec==0.7.0 # via black
pathspec==0.8.0 # via black
pep8-naming==0.4.1 # via prospector
pexpect==4.8.0 # via ipython
pickleshare==0.7.5 # via ipython
pillow==7.0.0
pip-tools==4.4.1
pillow==7.2.0
pip-tools==5.3.0
plaster-pastedeploy==0.7 # via pyramid
plaster==1.0 # via plaster-pastedeploy, pyramid
pluggy==0.13.1 # via pytest
prometheus-client==0.7.1
prompt-toolkit==3.0.3 # via ipython
prometheus-client==0.8.0
prompt-toolkit==3.0.5 # via ipython
prospector==1.2.0
psycopg2==2.8.4
psycopg2==2.8.5
ptyprocess==0.6.0 # via pexpect
publicsuffix2==2.20160818
py==1.8.1 # via pytest
py==1.9.0 # via pytest
pycodestyle==2.4.0 # via prospector
pycparser==2.19 # via cffi
pycparser==2.20 # via cffi
pydocstyle==5.0.2 # via prospector
pyflakes==2.1.1 # via prospector
pygit2==1.0.3
pygments==2.5.2
pygit2==1.2.1
pygments==2.6.1
pylint-celery==0.3 # via prospector
pylint-django==2.0.12 # via prospector
pylint-flask==0.6 # via prospector
pylint-plugin-utils==0.6 # via prospector, pylint-celery, pylint-django, pylint-flask
pylint==2.4.4 # via prospector, pylint-celery, pylint-django, pylint-flask, pylint-plugin-utils
pyotp==2.3.0
pyparsing==2.4.6 # via packaging
pyramid-debugtoolbar==4.6
pyotp==2.4.0
pyparsing==2.4.7 # via packaging
pyramid-debugtoolbar==4.6.1
pyramid-ipython==0.2
pyramid-jinja2==2.8
pyramid-mako==1.1.0 # via pyramid-debugtoolbar
......@@ -73,48 +75,48 @@ pyramid-session-redis==1.5.0
pyramid-tm==2.4
pyramid-webassets==0.10
pyramid==1.10.4
pytest-mock==2.0.0
pytest==5.3.5
pytest-mock==3.2.0
pytest==6.0.0
python-dateutil==2.8.1
python-editor==1.0.4 # via alembic
pyyaml==5.3
pyyaml==5.3.1
qrcode==6.1
redis==3.4.1
regex==2020.1.8 # via black
redis==3.5.3
regex==2020.7.14 # via black, titlecase
repoze.lru==0.7 # via pyramid-debugtoolbar
requests==2.22.0
requirements-detector==0.6 # via prospector
sentry-sdk==0.14.1
requests==2.24.0
requirements-detector==0.7 # via prospector
sentry-sdk==0.16.2
setoptconf==0.2.0 # via prospector
simplejson==3.17.0 # via cornice
six==1.14.0 # via argon2-cffi, astroid, bleach, cornice, freezegun, html5lib, packaging, pip-tools, pyramid-session-redis, pyramid-webassets, python-dateutil, qrcode, sqlalchemy-utils, traitlets, webtest
six==1.15.0 # via argon2-cffi, astroid, bleach, freezegun, html5lib, packaging, pip-tools, pyramid-session-redis, pyramid-webassets, python-dateutil, qrcode, sqlalchemy-utils, traitlets, webtest
snowballstemmer==2.0.0 # via pydocstyle
soupsieve==1.9.5 # via beautifulsoup4
sqlalchemy-utils==0.36.1
sqlalchemy==1.3.13
stripe==2.42.0
soupsieve==2.0.1 # via beautifulsoup4
sqlalchemy-utils==0.36.8
sqlalchemy==1.3.18
stripe==2.49.0
testing.common.database==2.0.3 # via testing.redis
testing.redis==1.1.1
titlecase==0.12.0
toml==0.10.0 # via black
titlecase==1.1.1
toml==0.10.1 # via black, pytest
traitlets==4.3.3 # via ipython
transaction==3.0.0 # via pyramid-tm, zope.sqlalchemy
translationstring==1.3 # via pyramid
translationstring==1.4 # via pyramid
typed-ast==1.4.1 # via black, mypy
typing-extensions==3.7.4.1 # via mypy
urllib3==1.25.8 # via requests, sentry-sdk
typing-extensions==3.7.4.2 # via mypy
urllib3==1.25.10 # via requests, sentry-sdk
venusian==3.0.0 # via cornice, pyramid
waitress==1.4.3 # via webtest
wcwidth==0.1.8 # via prompt-toolkit, pytest
waitress==1.4.4 # via webtest
wcwidth==0.2.5 # via prompt-toolkit
webargs==5.5.3
webassets==2.0 # via pyramid-webassets
webencodings==0.5.1 # via bleach, html5lib
webob==1.8.6 # via pyramid, webtest
webtest==2.0.34
webtest==2.0.35
wrapt==1.11.2
zope.deprecation==4.4.0 # via pyramid, pyramid-jinja2
zope.interface==4.7.1 # via pyramid, pyramid-webassets, transaction, zope.sqlalchemy
zope.sqlalchemy==1.2
zope.interface==5.1.0 # via pyramid, pyramid-webassets, transaction, zope.sqlalchemy
zope.sqlalchemy==1.3
# The following packages are considered to be unsafe in a requirements file:
# pip
# setuptools
......@@ -34,6 +34,6 @@ SQLAlchemy
SQLAlchemy-Utils
stripe
titlecase
webargs
webargs==5.5.3
wrapt
zope.sqlalchemy
ago==0.0.93
alembic==1.3.3
argon2-cffi==19.2.0
backcall==0.1.0 # via ipython
beautifulsoup4==4.8.2
bleach==3.1.0
certifi==2019.11.28 # via requests, sentry-sdk
cffi==1.13.2 # via argon2-cffi, pygit2
alembic==1.4.2
argon2-cffi==20.1.0
backcall==0.2.0 # via ipython
beautifulsoup4==4.9.1
bleach==3.1.5
cached-property==1.5.1 # via pygit2
certifi==2020.6.20 # via requests, sentry-sdk
cffi==1.14.1 # via argon2-cffi, pygit2
chardet==3.0.4 # via requests
click==7.0
cornice==4.0.1
decorator==4.4.1 # via ipython, traitlets
click==7.1.2
cornice==5.0.1
decorator==4.4.2 # via ipython, traitlets
gunicorn==20.0.4
html5lib==1.0.1
hupper==1.9.1 # via pyramid
idna==2.8 # via requests
html5lib==1.1
hupper==1.10.2 # via pyramid
idna==2.10 # via requests
ipython-genutils==0.2.0 # via traitlets
ipython==7.12.0
jedi==0.16.0 # via ipython
jinja2==2.11.1 # via pyramid-jinja2
mako==1.1.1 # via alembic
ipython==7.16.1
jedi==0.17.2 # via ipython
jinja2==2.11.2 # via pyramid-jinja2
mako==1.1.3 # via alembic
markupsafe==1.1.1 # via jinja2, mako, pyramid-jinja2
marshmallow==3.4.0
parso==0.6.1 # via jedi
marshmallow==3.7.1
packaging==20.4 # via bleach
parso==0.7.1 # via jedi
pastedeploy==2.1.0 # via plaster-pastedeploy
pexpect==4.8.0 # via ipython
pickleshare==0.7.5 # via ipython
pillow==7.0.0
pip-tools==4.4.1
pillow==7.2.0
pip-tools==5.3.0
plaster-pastedeploy==0.7 # via pyramid
plaster==1.0 # via plaster-pastedeploy, pyramid
prometheus-client==0.7.1
prompt-toolkit==3.0.3 # via ipython
psycopg2==2.8.4
prometheus-client==0.8.0
prompt-toolkit==3.0.5 # via ipython
psycopg2==2.8.5
ptyprocess==0.6.0 # via pexpect
publicsuffix2==2.20160818
pycparser==2.19 # via cffi
pygit2==1.0.3
pygments==2.5.2
pyotp==2.3.0
pycparser==2.20 # via cffi
pygit2==1.2.1
pygments==2.6.1
pyotp==2.4.0
pyparsing==2.4.7 # via packaging
pyramid-ipython==0.2
pyramid-jinja2==2.8
pyramid-session-redis==1.5.0
......@@ -46,32 +49,33 @@ pyramid-webassets==0.10
pyramid==1.10.4
python-dateutil==2.8.1
python-editor==1.0.4 # via alembic
pyyaml==5.3
pyyaml==5.3.1
qrcode==6.1
redis==3.4.1
requests==2.22.0
sentry-sdk==0.14.1
simplejson==3.17.0 # via cornice
six==1.14.0 # via argon2-cffi, bleach, cornice, html5lib, pip-tools, pyramid-session-redis, pyramid-webassets, python-dateutil, qrcode, sqlalchemy-utils, traitlets
soupsieve==1.9.5 # via beautifulsoup4
sqlalchemy-utils==0.36.1
sqlalchemy==1.3.13
stripe==2.42.0
titlecase==0.12.0
redis==3.5.3
regex==2020.7.14 # via titlecase
requests==2.24.0
sentry-sdk==0.16.2
six==1.15.0 # via argon2-cffi, bleach, html5lib, packaging, pip-tools, pyramid-session-redis, pyramid-webassets, python-dateutil, qrcode, sqlalchemy-utils, traitlets
soupsieve==2.0.1 # via beautifulsoup4
sqlalchemy-utils==0.36.8
sqlalchemy==1.3.18
stripe==2.49.0
titlecase==1.1.1
traitlets==4.3.3 # via ipython
transaction==3.0.0 # via pyramid-tm, zope.sqlalchemy
translationstring==1.3 # via pyramid
urllib3==1.25.8 # via requests, sentry-sdk
translationstring==1.4 # via pyramid
urllib3==1.25.10 # via requests, sentry-sdk
venusian==3.0.0 # via cornice, pyramid
wcwidth==0.1.8 # via prompt-toolkit
wcwidth==0.2.5 # via prompt-toolkit
webargs==5.5.3
webassets==2.0 # via pyramid-webassets
webencodings==0.5.1 # via bleach, html5lib
webob==1.8.6 # via pyramid
wrapt==1.11.2
wrapt==1.12.1
zope.deprecation==4.4.0 # via pyramid, pyramid-jinja2
zope.interface==4.7.1 # via pyramid, pyramid-webassets, transaction, zope.sqlalchemy
zope.sqlalchemy==1.2
zope.interface==5.1.0 # via pyramid, pyramid-webassets, transaction, zope.sqlalchemy
zope.sqlalchemy==1.3
# The following packages are considered to be unsafe in a requirements file:
# pip
# setuptools
......@@ -152,7 +152,7 @@ def addhashes(filename: str) -> None:
hashval = hashval.split(":")[0]
command = generate_redis_protocol("BF.ADD", BREACHED_PASSWORDS_BF_KEY, hashval)
redis_pipe.stdin.write(command)
redis_pipe.stdin.write(command) # type: ignore
if count % update_interval == 0:
progress_bar.update(update_interval)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment