Commit 4dc99d9f authored by Deimos's avatar Deimos

Vagrantfile: pin Salt version to 2019.2.3

The new version of Salt ("3000") seems to have a number of bugs,
including not being able to handle "unless" checks, which the Tildes
states use frequently. Because of this, creating a new dev environment
currently doesn't work. This pins Salt to the previous stable version
for now.

Here's the relevant bug for "unless" specifically:
https://github.com/saltstack/salt/issues/56131

And the overall release notes:
https://docs.saltstack.com/en/latest/topics/releases/3000.html
parent 97e8d756
......@@ -23,6 +23,9 @@ Vagrant.configure(VAGRANT_CONFIG_VERSION) do |config|
salt.run_highstate = true
salt.verbose = true
salt.log_level = "info"
salt.install_type = "stable"
salt.version = "2019.2.3"
end
config.vm.provider "virtualbox" do |vb|
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment