[UPD] adding minimum php version (seems to be 7.1.3 as that's the requirement...

[UPD] adding minimum php version (seems to be 7.1.3 as that's the requirement of a lot of libs we have) and running composer update, with php 7.2 again, but now we have 7.1 in the platform requirement it has downgraded several packages as required (e.g. symfony/css-selector back to 4.x)
Thanks @guill for the tip, and apologies to @luciash for the breakage in 2ee20788, hope this fixes it!

  - Updating bower-asset/fontawesome (5.12.1 => 5.13.0)
  - Updating league/commonmark (1.3.1 => 1.3.2)
  - Updating phpseclib/phpseclib (2.0.25 => 2.0.26)
  - Updating studio-42/elfinder (2.1.54 => 2.1.55)
  - Downgrading symfony/dom-crawler (v5.0.5 => v4.4.5)
  - Downgrading symfony/browser-kit (v5.0.5 => v4.4.5)
  - Downgrading symfony/css-selector (v5.0.5 => v4.4.5)
  - Updating psr/log (1.1.2 => 1.1.3)
  - Downgrading phpdocumentor/type-resolver (1.1.0 => 1.0.1)
  - Downgrading phpdocumentor/reflection-docblock (5.1.0 => 4.3.4)
22 jobs for 20.x in 7 minutes and 44 seconds (queued for 16 seconds)
Status Job ID Name Coverage
  Build
passed #501206490
composer

00:02:13

 
  Lint
passed #501206518
phpcs

00:01:56

passed #501206532
phplint

00:01:51

 
  Vendors Security
failed #501206600
sensiolabs-vendor-bundled-security-check

00:01:18

failed #501206576
sensiolabs-vendor-security-check

00:03:34

 
  Tiki Check
skipped #501206754
allowed to fail
composer-lock
skipped #501206829
db-upgrade-12-lts
skipped #501206800
db-upgrade-15-lts
skipped #501206822
db-upgrade-15-lts-10.2-mariadb
skipped #501206816
db-upgrade-15-lts-5.5-mariadb
skipped #501206793
db-upgrade-17
skipped #501206766
db-upgrade-18-lts
skipped #501206779
db-upgrade-18-lts-myisam
skipped #501206678
schema-naming-convention
skipped #501206649
schema-sql-drop
skipped #501206627
sql-engine
skipped #501206833
sql-engine-conversion
skipped #501206696
allowed to fail
translation
skipped #501206735
allowed to fail
translation-standards
 
  Unit Tests
skipped #501206845
unit-tests-71
skipped #501206863
unit-tests-72
skipped #501206878
allowed to fail
unit-tests-73
 
Name Stage Failure
failed
sensiolabs-vendor-bundled-security-check Vendors Security
Downloading artifacts
Downloading artifacts for composer (501206490)...
Downloading artifacts from coordinator... ok
id=501206490 responseStatus=200 OK token=oMssZsoi
Running before_script and script
$ php bin/security-checker security:check vendor_bundled/composer.lock
Could not open input file: bin/security-checker
Running after_script
Uploading artifacts for failed job
ERROR: Job failed: exit code 1
failed
sensiolabs-vendor-security-check Vendors Security
    - /etc/php/7.2/cli/conf.d/20-xmlwriter.ini
- /etc/php/7.2/cli/conf.d/20-xsl.ini
- /etc/php/7.2/cli/conf.d/20-zip.ini
You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

Installation failed, reverting ./composer.json to its original content.
Running after_script
Uploading artifacts for failed job
ERROR: Job failed: exit code 1