Commit e630b961 authored by chealer's avatar chealer

[FIX] POLL plugin: error page embedded in parse output when pollId is missing (from 1.1.2.1)

parent 1af1fdbf
...@@ -57,8 +57,7 @@ function wikiplugin_poll($data, $params) { ...@@ -57,8 +57,7 @@ function wikiplugin_poll($data, $params) {
extract ($params,EXTR_SKIP); extract ($params,EXTR_SKIP);
if (!isset($pollId)) { if (!isset($pollId)) {
$smarty->assign('msg', tra("missing poll ID for plugin POLL")); return WikiParser_PluginOutput::argumentError(array('pollId'));
return $smarty->fetch("error_simple.tpl");
} }
global $polllib;include_once ('lib/polls/polllib.php'); global $polllib;include_once ('lib/polls/polllib.php');
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment