Commit a6e3fd42 authored by Vianney Rwicha's avatar Vianney Rwicha 💻 Committed by Marc Laporte
Browse files

[REF] replace the old version(1.0) to (2.0) of melbahja/seo in satis.json

parent bf89c509
Pipeline #416803515 passed with stages
in 11 minutes and 46 seconds
......@@ -1899,7 +1899,7 @@
"drmonty/smartmenus": ">=1.1.0",
"enygma/expose": "^3.0",
"erusev/parsedown": "1.8.0-beta-5",
"melbahja/seo": "^1.0",
"melbahja/seo": ">=2.0.0",
"ezyang/htmlpurifier": ">=4.5.0",
"fabpot/goutte": "^3.3",
"fortawesome/font-awesome": "4.5.0||~4.7.0",
......
  • @vianneyrwicha2017 @marclaporte

    The satis packages need to be inline with the composer requirements. Now we cannot update the dependencies, due to a package failure.

    In vendor_bundled/composer.json

    "melbahja/seo": "^1.0",

    When running composer update for example this is the output:

    Your requirements could not be resolved to an installable set of packages.
    
      Problem 1
        - Root composer.json requires melbahja/seo ^1.0, it is satisfiable by melbahja/seo[v1.0.0, v1.0.1, v1.0.2] from composer repo (https://repo.packagist.org) but melbahja/seo[dev-master, v2.0.0] from composer repo (https://composer.tiki.org) has higher repository priority. The packages with higher priority do not match your constraint and are therefore not installable. See https://getcomposer.org/repoprio for details and assistance.
  • Thanks @xorti

    Yes, dependencies should not be removed from satis.json because other supported branches of tiki will still be using them, and are now broken (i thought we discussed this somewhere @marclaporte, no?)

    Please re-add the 1.0 dependency ASAP, thanks.

  • @jonnybradley Fixed here !1099 (merged)

    We now have v1 and v2 available in composer.tiki.org packages

    cc/ @marclaporte @vianneyrwicha2017

  • Thank you @jonnybradley and @xorti and sorry about that.

    So we need to do this again for v3? Is there not a way to indicate that we want all future versions as they are released?

    Thanks!

  • Hi @marclaporte yes, to v3 we need to add that. We can use >=1.0.0, although IMO, it is preferred to version in on satis as we need them, (this obviously for major versions).

Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment