Commit 9af9b578 authored by marclaporte's avatar marclaporte

Update documentation on some legacy files in case some new developers go...

Update documentation on some legacy files in case some new developers go poking in there and find it confusing
parent 307dbcfd
# $Id$
#
# IMPORTANT: If you are upgrading from 1.8.x, you first need to upgrade your data to 1.9.x before upgrading to 2.x and up.
# You can do this either by
# - installing a Tiki 1.9.11 (which you can find at http://sourceforge.net/projects/tikiwiki/files/) and running the installer: http://doc.tiki.org/Upgrade+1.8.x+to+1.9.y
# - or applying tiki_1.8to1.9.sql manually
#
#
# This approach of making one .sql file per version is obsolete. The new system is explained at: http://dev.tiki.org/Database+Schema+Upgrade
#
#
# The following script will update a tiki database from version 1.8.x to 1.9.x
# The following script will ALSO update from version 1.9.x to 1.9.y
#
......
# $Id$
# The following script will update a tiki database from version 1.9 to 1.10
#
# If you are using Tiki 3.x or later, this script will automatically be run by the installer when it detects that your data is from pre 3.x
#
# This approach of making one .sql file per version is obsolete. The new system is explained at: http://dev.tiki.org/Database+Schema+Upgrade
#
#
#
# The following script will update a Tiki database from version 1.9 to 2.0 (which was previously named 1.10)
#
# To execute this file do the following:
#
# $ mysql -f dbname < tiki_1.9to1.10.sql
# $ mysql -f dbname < tiki_1.9to2.0.sql
#
# where dbname is the name of your tiki database.
#
# For example, if your tiki database is named tiki (not a bad choice), type:
#
# $ mysql -f tiki < tiki_1.9to1.10.sql
# $ mysql -f tiki < tiki_1.9to2.0.sql
#
# You may execute this command as often as you like,
# and may safely ignore any error messages that appear.
......
# $Id: tiki_2.0to3.0.sql 13749 2008-07-19 23:57:28Z m_stef $
# ATTENTION:
# This file is now obsolete. To modify the database, simply add a file to the installer/schema/
# directory. For more information, see http://dev.tikiwiki.org/DatabaseSchemaUpgrade
# The following script will update a tiki database from version 2.0 to 3.0
#
# If you are using Tiki 3.x or later, this script will automatically be run by the installer when it detects that your data is from pre 3.x
#
# This approach of making one .sql file per version is obsolete. The new system is explained at: http://dev.tiki.org/Database+Schema+Upgrade
#
#
#
# The following script will update a Tiki database from version 2.0 to 3.0
#
# To execute this file do the following:
#
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment