Made finding the __init__ file relative to the doc/conf.py file rather than the cwd

7 jobs for v0.11.3 in 6 minutes and 2 seconds
latest
Status Job ID Name Coverage
  Test
passed #666642829
lint

00:02:26

passed #666642830
test

00:02:02

40.0%
 
  Build
passed #666642831
build

00:01:59

failed #666642832
allowed to fail
build_flatpak

00:02:19

 
  Deploy
failed #666642833
deploy_pypi

00:01:17

 
  Verify
skipped #666642834
verify_deploy
 
  Release
skipped #666642835
publish_release
 
Name Stage Failure
failed
deploy_pypi Deploy
Uploading sublime-music-0.11.2.tar.gz
0%| | 0.00/149k [00:00<?, ?B/s] 70%|██████▉ | 104k/149k [00:00<00:00, 998kB/s] 100%|██████████| 149k/149k [00:00<00:00, 309kB/s]
NOTE: Try --verbose to see response content.
HTTPError: 400 Bad Request from https://test.pypi.org/legacy/
File already exists. See https://test.pypi.org/help/#file-name-reuse for more information.
Running after_script
Running after script...
$ echo "" > ~/.pypirc && rm -f ~/.pypirc
ERROR: Job failed: exit code 1
failed
build_flatpak Build
$ ./flatpak_build.sh
+ REPO=/repo
+ APPID=app.sublimemusic.SublimeMusic
+ rm -rf flatpak-builder-tools
+ git clone https://github.com/flatpak/flatpak-builder-tools.git
Cloning into 'flatpak-builder-tools'...
+ python3 ./flatpak-builder-tools/pip/flatpak-pip-generator --requirements-file=flatpak-requirements.txt --output pypi-dependencies
Requirements modules is not installed. Run "pip install requirements-parser"
ERROR: Job failed: exit code 1