Verified Commit d454b900 authored by Sumner Evans's avatar Sumner Evans 💬

Update Flatpak install instructions

parent 02ae1a88
Pipeline #194342356 passed with stages
in 25 minutes and 15 seconds
......@@ -38,11 +38,12 @@ tasks:
- build: |
python setup.py sdist
- deploy-pypi: |
./cicd/run_if_tagged_with_version \
"twine upload -r testpypi dist/*" \
"twine upload dist/*"
# TODO migrate deploy to sr.ht
# - deploy-pypi: |
# ./cicd/run_if_tagged_with_version \
# "twine upload -r testpypi dist/*" \
# "twine upload dist/*"
- verify-pypi: |
./cicd/run_if_tagged_with_version \
"pip install ${REPO_NAME}"
# - verify-pypi: |
# ./cicd/run_if_tagged_with_version \
# "pip install ${REPO_NAME}"
......@@ -2,7 +2,8 @@ v0.11.9
=======
**The wait is over!** Thanks to help from jlanda_, the **Flatpak** is back! The
Flatpak requires ``org.gnome.SDK//3.38`` and ``org.gnome.Platform//3.38``.
Flatpak requires ``org.gnome.SDK//3.38`` and ``org.gnome.Platform//3.38`` to be
installed on your system.
.. _jlanda: https://gitlab.com/jlanda
......
......@@ -111,11 +111,19 @@ In the future, you will be able to install via Flathub. For now, if you want to
try the Flatpak, you will have to install it manually by visiting the Releases_
page and downloading the ``.flatpak`` file from there.
Then, you can install Sublime Music with::
Next, install the dependencies for Sublime Music. If you haven't already, follow
the instructions to setup ``flathub`` here:
https://docs.flatpak.org/en/latest/using-flatpak.html#add-a-remote
Then, install the dependencies of Sublime Music::
sudo flatpak install -y org.gnome.Platform//3.38 org.gnome.Sdk//3.38
And finally, install Sublime Music with::
sudo flatpak install sublime-music.flatpak
and run it by executing::
To run Sublime, use the following command::
flatpak run app.sublimemusic.SublimeMusic
......
......@@ -115,11 +115,19 @@ In the future, you will be able to install via Flathub. For now, if you want to
try the Flatpak, you will have to install it manually by visiting the Releases_
page and downloading the ``.flatpak`` file from there.
Then, you can install Sublime Music with::
Next, install the dependencies for Sublime Music. If you haven't already, follow
the instructions to setup ``flathub`` here:
https://docs.flatpak.org/en/latest/using-flatpak.html#add-a-remote
Then, install the dependencies of Sublime Music::
sudo flatpak install -y org.gnome.Platform//3.38 org.gnome.Sdk//3.38
And finally, install Sublime Music with::
sudo flatpak install sublime-music.flatpak
and run it by executing::
To run Sublime, use the following command::
flatpak run app.sublimemusic.SublimeMusic
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment