Commit 11742254 authored by Stefan Cameron's avatar Stefan Cameron
Browse files

Update all dependencies to latest; fix slim build issue

parent c1710a04
Pipeline #277615211 passed with stages
in 3 minutes and 16 seconds
......@@ -7,6 +7,12 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
Date format is YYYY-MM-DD.
## UNRELEASED
### Changed
- Fixed: The slim builds weren't actually slim! They were still bundling `@babel/runtime` and `lodash`. Note this change doesn't affect the default use of the package, which points to the full builds that bundle everything.
## 3.1.3
Release date: 2021-01-30
......
......@@ -6,8 +6,8 @@ Thank you for considering a contribution to RTV.js!
Local development is straightforward. Use the following versions of Node.js and npm:
* Node.js: `>=10.11.0`
* npm: `>=6.4.1`
* Node.js: `>=10.21.0`
* npm: `>=7..0.0`
Install all project dependencies:
......
This diff is collapsed.
......@@ -4,7 +4,7 @@
"description": "Runtime Verification Library for browsers and Node.js.",
"engines": {
"node": ">=10.21.0",
"npm": ">=6"
"npm": ">=7"
},
"main": "dist/rtv.js",
"module": "dist/rtv.esm.js",
......@@ -84,32 +84,32 @@
"dist/"
],
"devDependencies": {
"@babel/core": "^7.12.10",
"@babel/plugin-transform-runtime": "^7.12.10",
"@babel/preset-env": "^7.12.11",
"@babel/register": "^7.12.10",
"@babel/runtime": "^7.12.5",
"@rollup/plugin-babel": "^5.2.2",
"@rollup/plugin-commonjs": "^17.0.0",
"@babel/core": "^7.13.13",
"@babel/plugin-transform-runtime": "^7.13.10",
"@babel/preset-env": "^7.13.12",
"@babel/register": "^7.13.8",
"@babel/runtime": "^7.13.10",
"@rollup/plugin-babel": "^5.3.0",
"@rollup/plugin-commonjs": "^18.0.0",
"@rollup/plugin-json": "^4.1.0",
"@rollup/plugin-node-resolve": "^11.0.1",
"@rollup/plugin-replace": "^2.3.4",
"@rollup/plugin-node-resolve": "^11.2.1",
"@rollup/plugin-replace": "^2.4.2",
"babel-eslint": "^10.1.0",
"babel-plugin-istanbul": "^6.0.0",
"chai": "^4.2.0",
"chai": "^4.3.4",
"codecov": "^3.8.1",
"eslint": "^7.16.0",
"eslint-config-prettier": "^7.1.0",
"eslint": "^7.23.0",
"eslint-config-prettier": "^8.1.0",
"eslint-plugin-node": "^11.1.0",
"jsdoc-to-markdown": "^6.0.1",
"jsdoc-to-markdown": "^7.0.1",
"live-server": "^1.2.1",
"lodash": "^4.17.20",
"mocha": "^8.2.1",
"lodash": "^4.17.21",
"mocha": "^8.3.2",
"nyc": "^15.1.0",
"pre-commit": "^1.2.2",
"prettier": "^2.2.1",
"rollup": "^2.35.1",
"rollup": "^2.43.0",
"rollup-plugin-terser": "^7.0.2",
"sinon": "^9.2.2"
"sinon": "^10.0.0"
}
}
......@@ -95,8 +95,13 @@ const getBaseConfig = function (
throw new Error(`A valid output format is required, format=${format}`);
}
// slim builds bundle noting; fat ones bundle everything
const externals = isSlim ? Object.keys(pkg.peerDependencies || {}) : []; // {Array<string>}
// {Array<string>} slim builds bundle noting; fat ones bundle everything
// NOTE: we do not put `peerDependencies` in package.json because the default
// distributions referenced via `main` and `module` are the full versions
// that bundle everything; adding peer dependencies to the package would
// result in "missing peer dependency" warnings on installation, which
// technically aren't true for the package's default use
const externals = isSlim ? ['@babel/runtime', 'lodash'] : [];
if (isSlim && format === RU_FORMAT_UMD) {
// never mark @babel/runtime dependencies as external for UMD because
......@@ -135,7 +140,10 @@ const getBaseConfig = function (
},
plugins: [
// ALWAYS FIRST: string token replacement
replacePlugin(replaceTokens),
replacePlugin({
...replaceTokens,
preventAssignment: true,
}),
jsonPlugin(),
resolvePlugin(),
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment