Commit 6f61d605 authored by Campbell Jones's avatar Campbell Jones 💬
Browse files

Update README.md

parent ab8c7274
......@@ -8,18 +8,28 @@
Wraith Master is a graphical and command-line application for controlling the RGB LEDs on AMD's Wraith stock coolers. At the moment, the only supported cooler is the Wraith Prism, but there are plans to add other Wraith coolers as well.
Designed for feature parity with the official Windows-only Cooler Master application, Wraith Master supports all modes and settings that the Wraith Prism is capable of handling. Only one feature remains to be implemented (fan mirage color frequencies).
Designed for feature parity with the official Windows-only Cooler Master application, Wraith Master is intended to support all modes and settings that the Wraith Prism can use. Only one feature remains to be implemented (fan mirage color frequencies). As the Wraith coolers are capable of storing RGB configurations in-device, no daemon is required to maintain configurations, and the program can be uninstalled without fear of losing your settings.
## Supported Platforms
Wraith Master supports all 64-bit Linux distributions that use glibc as their libc implementation. This dependence on glibc is not my choice, but a limitation of the software stack; Kotlin/Native is [incompatible with musl](https://github.com/JetBrains/kotlin-native/issues/3771) as of the time I am writing this. Once it gains compatibility with more libc implementations, I fully intend to take advantage of that compatibility. I am open to bringing Wraith Master to Windows as well, if there is demand for it.
## Installing
There are precompiled binaries available for each release [here](https://gitlab.com/serebit/wraith-master/-/releases). Some Linux distributions have alternate installation methods, which are detailed below.
#### Arch/Derivatives
If you're on Arch Linux or one of its derivatives, you can install both frontends [from the AUR](https://aur.archlinux.org/packages/?K=wraith%2Dmaster), under `wraith-master-cli` for the CLI frontend and `wraith-master-gtk` for the GTK frontend.
#### Solus
Solus has both frontends in the official repository. They can be installed either by running `sudo eopkg it wraith-master` in the terminal, or searching for the package in the Software Center.
## Screenshots
![Screenshot][wraith-master-screenshot]
## Building from Source
### Build Dependencies
......@@ -70,13 +80,9 @@ This will install the packages in `/usr/local` by default. To change the install
See `CHANGELOG.md` for notes on previous releases, along with changes that are currently in staging for the next release.
## Screenshots
![Screenshot][wraith-master-screenshot]
## License
Wraith Master is open-sourced under the [Apache License, Version 2.0](https://www.apache.org/licenses/LICENSE-2.0.html). In simple terms, this license allows you to do whatever you want with the software, so long as the required notices are included.
Wraith Master is open-sourced under the [Apache License, Version 2.0](https://www.apache.org/licenses/LICENSE-2.0.html).
## Acknowledgements
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment