Set minimum required GnuTLS version to 3.6.13

Upgrade to a baseline requirement of GnuTLS 3.6.13, replace Ubuntu 18.04 with Ubuntu 22.04.

Motivated by the desire not to have samr_ChangePasswordUser4 be conditional in the codebase behind HAVE_GNUTLS_PBKDF2

This allows the removal of all our in-tree AES cryptography, now provided entirely by GnuTLS!

The plan is that before 4.19pre1 we merge this so the autobuild host and the CI image can match as Ubuntu 22.04.

Checklist

  • Commits have Signed-off-by: with name/author being identical to the commit author
  • (optional) This MR is just one part towards a larger feature.
  • (optional, if backport required) Bugzilla bug filed and BUG: tag added
  • Test suite updated with functionality tests
  • Test suite updated with negative tests
  • Documentation updated
  • CI timeout is 3h or higher (see Settings/CICD/General pipelines/ Timeout)

Reviewer's checklist:

  • There is a test suite reasonably covering new functionality or modifications
  • Function naming, parameters, return values, types, etc., are consistent and according to README.Coding.md
  • This feature/change has adequate documentation added
  • No obvious mistakes in the code
Edited by Andrew Bartlett

Merge request reports