Commit eb7226b6 by Gabriel Mazetto

Merge branch 'nodeless-build' into 'source'

Atualiza gems e remove dependência do NodeJS

Removi a dependência do NodeJS (que era usado apenas na etapa de compilação do Javascript). A tarefa é feita pela gem ~~`mini_racer`~~  `therubyracer`.

See merge request !3
parents b70766ab fdbe96f3
Pipeline #5050782 passed with stages
in 3 minutes 53 seconds
......@@ -6,8 +6,6 @@ cache:
- vendor/
before_script:
- curl -sL https://deb.nodesource.com/setup_5.x | bash -
- apt-get install -y nodejs
- which ruby
- bundle install --deployment --jobs $(nproc)
......
......@@ -10,9 +10,9 @@ gem 'tzinfo-data', platforms: [:mswin, :mingw, :jruby]
# Middleman Gems
gem 'middleman-livereload'
gem 'middleman', '>= 4.0.0'
gem 'middleman-blog', '>= 4.0.0'
gem 'middleman-sprockets', '~> 4.0.0.rc'
gem 'middleman', '4.1.7'
gem 'middleman-blog', '~> 4.0'
gem 'middleman-sprockets', '~> 4.1.0'
gem 'middleman-deploy', '2.0.0.pre.alpha'
gem 'middleman-google-analytics', '~> 2.0'
gem "middleman-disqus"
......@@ -21,8 +21,11 @@ gem "middleman-disqus"
gem 'builder', '~> 3.2.2'
# Code syntax highlighting
gem 'middleman-syntax', '~> 2.1.0'
gem 'middleman-syntax', '~> 3.0'
gem 'redcarpet', '~> 3.3.4'
# Asset pipeline
gem 'therubyracer'
# For "summary"-Helper
gem 'nokogiri', '~> 1.6.7.1'
GEM
remote: https://rubygems.org/
specs:
activesupport (4.2.5.1)
activesupport (4.2.7.1)
i18n (~> 0.7)
json (~> 1.7, >= 1.7.7)
minitest (~> 5.1)
thread_safe (~> 0.3, >= 0.3.4)
tzinfo (~> 1.1)
addressable (2.4.0)
addressable (2.5.0)
public_suffix (~> 2.0, >= 2.0.2)
backports (3.6.8)
builder (3.2.2)
capybara (2.5.0)
......@@ -22,56 +23,58 @@ GEM
coffee-script-source (1.10.0)
compass-import-once (1.0.5)
sass (>= 3.2, < 3.5)
concurrent-ruby (0.9.2)
contracts (0.12.0)
concurrent-ruby (1.0.2)
contracts (0.13.0)
em-websocket (0.5.1)
eventmachine (>= 0.12.9)
http_parser.rb (~> 0.6.0)
erubis (2.7.0)
eventmachine (1.0.9.1)
execjs (2.6.0)
eventmachine (1.2.1)
execjs (2.7.0)
fast_blank (1.0.0)
fastimage (1.8.1)
addressable (~> 2.3, >= 2.3.5)
ffi (1.9.10)
fastimage (2.0.1)
addressable (~> 2)
ffi (1.9.14)
haml (4.0.7)
tilt
hamster (2.0.0)
concurrent-ruby (~> 0.8)
hashie (3.4.3)
hamster (3.0.0)
concurrent-ruby (~> 1.0)
hashie (3.4.6)
http_parser.rb (0.6.0)
i18n (0.7.0)
json (1.8.3)
kramdown (1.9.0)
listen (3.0.6)
rb-fsevent (>= 0.9.3)
rb-inotify (>= 0.9.7)
middleman (4.1.1)
kramdown (1.12.0)
libv8 (3.16.14.15)
listen (3.1.5)
rb-fsevent (~> 0.9, >= 0.9.4)
rb-inotify (~> 0.9, >= 0.9.7)
ruby_dep (~> 1.2)
middleman (4.1.7)
coffee-script (~> 2.2)
compass-import-once (= 1.0.5)
haml (>= 4.0.5)
kramdown (~> 1.2)
middleman-cli (= 4.1.1)
middleman-core (= 4.1.1)
middleman-cli (= 4.1.7)
middleman-core (= 4.1.7)
sass (>= 3.4.0, < 4.0)
middleman-blog (4.0.0)
addressable (~> 2.4.0)
middleman-blog (4.0.1)
addressable (~> 2.3)
middleman-core (>= 4.0.0)
tzinfo (>= 0.3.0)
middleman-cli (4.1.1)
middleman-cli (4.1.7)
thor (>= 0.17.0, < 2.0)
middleman-core (4.1.1)
middleman-core (4.1.7)
activesupport (~> 4.2)
addressable (~> 2.4.0)
addressable (~> 2.3)
backports (~> 3.6)
bundler (~> 1.1)
capybara (~> 2.5.0)
contracts (~> 0.12.0)
contracts (~> 0.13.0)
erubis
execjs (~> 2.0)
fast_blank
fastimage (~> 1.8)
hamster (~> 2.0)
fastimage (~> 2.0)
hamster (~> 3.0)
hashie (~> 3.4)
i18n (~> 0.7.0)
listen (~> 3.0)
......@@ -79,68 +82,76 @@ GEM
parallel
rack (>= 1.4.5, < 2.0)
sass (>= 3.4)
servolux
tilt (~> 1.4.1)
uglifier (~> 2.6)
uglifier (~> 3.0)
middleman-deploy (2.0.0.pre.alpha)
middleman-core (>= 3.2)
net-sftp
ptools
middleman-disqus (1.2.0)
middleman-core (~> 4.0)
middleman-google-analytics (2.1.0)
middleman-google-analytics (2.1.1)
activesupport (~> 4.1)
erubis
middleman-core (>= 3.4)
uglifier (~> 2.6)
uglifier (>= 2.5, < 4.0)
middleman-livereload (3.4.6)
em-websocket (~> 0.5.1)
middleman-core (>= 3.3)
rack-livereload (~> 0.3.15)
middleman-sprockets (4.0.0.rc.1)
middleman-core (>= 4.0.0.rc.1)
sprockets (~> 3.0)
middleman-syntax (2.1.0)
middleman-sprockets (4.1.0)
middleman-core (~> 4.0)
sprockets (>= 3.0)
middleman-syntax (3.0.0)
middleman-core (>= 3.2)
rouge (~> 1.0)
mime-types (3.0)
rouge (~> 2.0)
mime-types (3.1)
mime-types-data (~> 3.2015)
mime-types-data (3.2016.0221)
mime-types-data (3.2016.0521)
mini_portile2 (2.0.0)
minitest (5.8.4)
minitest (5.9.1)
net-sftp (2.1.2)
net-ssh (>= 2.6.5)
net-ssh (3.0.2)
net-ssh (3.2.0)
nokogiri (1.6.7.2)
mini_portile2 (~> 2.0.0.rc2)
padrino-helpers (0.13.1)
padrino-helpers (0.13.3.3)
i18n (~> 0.6, >= 0.6.7)
padrino-support (= 0.13.1)
tilt (~> 1.4.1)
padrino-support (0.13.1)
padrino-support (= 0.13.3.3)
tilt (>= 1.4.1, < 3)
padrino-support (0.13.3.3)
activesupport (>= 3.1)
parallel (1.6.1)
parallel (1.9.0)
ptools (1.3.3)
rack (1.6.4)
public_suffix (2.0.4)
rack (1.6.5)
rack-livereload (0.3.16)
rack
rack-test (0.6.3)
rack (>= 1.0)
rb-fsevent (0.9.7)
rb-fsevent (0.9.8)
rb-inotify (0.9.7)
ffi (>= 0.5.0)
redcarpet (3.3.4)
rouge (1.10.1)
sass (3.4.21)
sprockets (3.4.1)
ref (2.0.0)
rouge (2.0.7)
ruby_dep (1.5.0)
sass (3.4.22)
servolux (0.12.0)
sprockets (3.7.0)
concurrent-ruby (~> 1.0)
rack (> 1, < 3)
therubyracer (0.12.2)
libv8 (~> 3.16.14.0)
ref
thor (0.19.1)
thread_safe (0.3.5)
tilt (1.4.1)
tzinfo (1.2.2)
thread_safe (~> 0.1)
uglifier (2.7.2)
execjs (>= 0.3.0)
json (>= 1.8.0)
uglifier (3.0.3)
execjs (>= 0.3.0, < 3)
xpath (2.0.0)
nokogiri (~> 1.3)
......@@ -149,18 +160,19 @@ PLATFORMS
DEPENDENCIES
builder (~> 3.2.2)
middleman (>= 4.0.0)
middleman-blog (>= 4.0.0)
middleman (= 4.1.7)
middleman-blog (~> 4.0)
middleman-deploy (= 2.0.0.pre.alpha)
middleman-disqus
middleman-google-analytics (~> 2.0)
middleman-livereload
middleman-sprockets (~> 4.0.0.rc)
middleman-syntax (~> 2.1.0)
middleman-sprockets (~> 4.1.0)
middleman-syntax (~> 3.0)
nokogiri (~> 1.6.7.1)
redcarpet (~> 3.3.4)
therubyracer
tzinfo-data
wdm (~> 0.1.0)
BUNDLED WITH
1.11.2
1.13.6
......@@ -85,6 +85,8 @@ configure :development do
activate :livereload
end
activate :sprockets
###
# Helpers
###
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment