Commit 6f1037b1 authored by Jamie A. Jennings's avatar Jamie A. Jennings

Changed versions of each linux to current ones. Ensured that the "find"...

Changed versions of each linux to current ones.  Ensured that the "find" utility is installed (fedora did not have it) so that the new Makefile works.
parent 631b1ec2
Pipeline #141114380 passed with stage
in 1 minute and 2 seconds
FROM base/archlinux
FROM archlinux:20200407
ARG branch
RUN pacman -Syy --noconfirm
......
FROM centos:latest
FROM centos:8
ARG branch
RUN yum -y update && yum install -y epel-release
# The version of git distributed with Centos is old (1.8.3) and does
# The version of git distributed with Centos7 is old (1.8.3) and does
# not support the --depth option in 'git submodule update --checkout --depth 1'.
RUN yum -y remove git*
RUN yum -y install https://centos7.iuscommunity.org/ius-release.rpm
RUN yum -y install git2u-all
# Use this sequence of yum commands to fix this situation:
#RUN yum -y remove git*
#RUN yum -y install https://centos7.iuscommunity.org/ius-release.rpm
#RUN yum -y install git2u-all
# And also comment out this yum command, which works fine on Centos8:
RUN yum install -y git
RUN yum install -y gcc make readline readline-devel libbsd libbsd-devel
......
FROM fedora
FROM fedora:32
ARG branch
RUN dnf -y update && dnf install -y \
gcc \
git \
make \
findutils \
readline-devel \
libbsd \
libbsd-devel
......
FROM ubuntu
FROM ubuntu:20.04
ARG branch
RUN apt-get -y update && apt-get install -y \
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment