Skip to content
  • Michael Baudino's avatar
    Comply .mk files to Buildroot coding style · 79d9b992
    Michael Baudino authored
    This commit makes all our `.mk` files compliant with the Buildroot
    coding style:
    https://buildroot.uclibc.org/downloads/manual/manual.html#_coding_style
    
    Specifically, this commit addresses 571 style offenses for the following
    rules:
    
    * consecutive empty lines
    * empty line at end of file
    * expected indent with tabs
    * line contains trailing whitespace
    * missing newline at end of file
    * remove default value of _SOURCE variable
    * remove trailing backslash
    * should be 1 hash
    * should be 80 hashes
    * should be a blank line
    * unexpected indent with tabs
    * useless default value
    * possible typo: ARMSNES_SITE
    * possible typo: ARMSNES_TARGET
    * possible typo: ARMSNES_VERSION
    * possible typo: GLUPEN64_PRE_CONFIGURE_HOOKS
    * possible typo: INITRAMFS_DIR
    * possible typo: KODI_PLUGIN_TARGET_DIR
    * possible typo: LIBRETRO_BOARD
    * possible typo: LIBRETRO_PLATFORM
    * possible typo: MUPEN64PLUS_GL_CFLAGS
    * possible typo: PKGCONFIG_CONFIG
    * possible typo: SDL_CONFIG
    * possible typo: SDL_FLAGS
    * possible typo: SDL_LIBS
    
    Buildroot check script has been run from the project root directory as
    follows:
    
    ```shell
    buildroot/utils/check-package {,custom/}package/**/*.mk
    ```
    79d9b992