Commit 6c9a3b94 authored by Sergio Costas's avatar Sergio Costas

Updated to version 0.8.1

parent d4868105
......@@ -33,20 +33,14 @@ endif()
find_package(PkgConfig)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} atk)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} cairo)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} gdk-3.0)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} gdk-pixbuf-2.0)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} gtk+-3.0)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} gee-0.8)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} gio-2.0)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} glib-2.0)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} gobject-2.0)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} gtk+-3.0)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} keybinder-3.0)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} pango)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} pangocairo)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} vte-2.91)
set(MODULES_TO_CHECK ${MODULES_TO_CHECK} x11)
pkg_check_modules(DEPS REQUIRED ${MODULES_TO_CHECK})
......
## History of versions ##
* Version 0.8.1 (2017-09-18)
* Fixed the install path when creating packages
* Fixed the gnome shell extension, now it works on gnome shell 3.24 and 3.26
* Forced GTK version to 3, to avoid compiling with GTK 4
* Version 0.8.0 (2017-08-01)
* Fixed some startup bugs
* Version 0.7.0 (2016-12-24)
......
pkgname=terminus
pkgver=0.8.0
pkgver=0.8.1
pkgrel=1
pkgdesc="A new terminal for XWindows
"
......
terminus (0.8.1-Debian1) sid; urgency=low
* Fixed the install path when creating packages
* Fixed the gnome shell extension, now it works on gnome shell 3.24 and 3.26
* Forced GTK version to 3, to avoid compiling with GTK 4
-- Sergio Costas Rodriguez <raster@rastersoft.com> Mon, 18 Sep 2017 23:55:00 +0200
terminus (0.8.0-Debian1) sid; urgency=low
* Fixed some startup bugs
......
......@@ -6,7 +6,7 @@ Build-Depends: build-essential, po-debconf, valac, libc6-dev, libatk1.0-dev, lib
Package: terminus
Architecture: any
Version: 0.8.0
Version: 0.8.1
Depends: libatk1.0-0, libglib2.0-0, libcairo2, libgtk-3-0, libpangocairo-1.0-0, libpango-1.0-0, libgdk-pixbuf2.0-0, libcairo-gobject2, libgee-0.8-2, libkeybinder-3.0-0, libvte-2.91-0, lib32z1, libgnutls30, libx11-6, libglib2.0-bin
Description: A new terminal for XWindows
.
terminus (0.8.1-Debian1) sid; urgency=low
* Fixed the install path when creating packages
* Fixed the gnome shell extension, now it works on gnome shell 3.24 and 3.26
* Forced GTK version to 3, to avoid compiling with GTK 4
-- Sergio Costas Rodriguez <raster@rastersoft.com> Mon, 18 Sep 2017 23:55:00 +0200
terminus (0.8.0-Debian1) sid; urgency=low
* Fixed some startup bugs
......
......@@ -6,7 +6,7 @@ Build-Depends: build-essential, po-debconf, valac, libc6-dev, libatk1.0-dev, lib
Package: terminus
Architecture: any
Version: 0.8.0
Version: 0.8.1
Depends: libatk1.0-0, libglib2.0-0, libcairo2, libgtk-3-0, libpangocairo-1.0-0, libpango-1.0-0, libgdk-pixbuf2.0-0, libcairo-gobject2, libgee-0.8-2, libkeybinder-3.0-0, libvte-2.91-0, libgnutls30, libx11-6, libglib2.0-bin
Description: A new terminal for XWindows
.
Name: terminus
Version: 0.8.0
Version: 0.8.1
Release: 1
License: Unknown/not set
Summary: A new terminal for XWindows
......
......@@ -7,13 +7,13 @@ set (GETTEXT_PACKAGE "terminus")
set (RELEASE_NAME "terminus")
set (CMAKE_C_FLAGS "")
set (PREFIX ${CMAKE_INSTALL_PREFIX})
set (VERSION "0.8.0")
set (VERSION "0.8.1")
set (TESTSRCDIR "${CMAKE_SOURCE_DIR}")
set (DOLLAR "$")
configure_file (${CMAKE_SOURCE_DIR}/src/Config.vala.base ${CMAKE_BINARY_DIR}/src/Config.vala)
add_definitions(-DGETTEXT_PACKAGE=\"${GETTEXT_PACKAGE}\")
set (VERSION "0.8.0")
set (VERSION "0.8.1")
add_definitions (${DEPS_CFLAGS})
link_libraries ( ${DEPS_LIBRARIES} )
link_directories ( ${DEPS_LIBRARY_DIRS} )
......@@ -23,20 +23,14 @@ ensure_vala_version ("0.30" MINIMUM)
include (ValaPrecompile)
set (VALA_PACKAGES ${VALA_PACKAGES} posix)
set (VALA_PACKAGES ${VALA_PACKAGES} atk)
set (VALA_PACKAGES ${VALA_PACKAGES} cairo)
set (VALA_PACKAGES ${VALA_PACKAGES} gdk-3.0)
set (VALA_PACKAGES ${VALA_PACKAGES} gdk-pixbuf-2.0)
set (VALA_PACKAGES ${VALA_PACKAGES} gtk+-3.0)
set (VALA_PACKAGES ${VALA_PACKAGES} gee-0.8)
set (VALA_PACKAGES ${VALA_PACKAGES} gio-2.0)
set (VALA_PACKAGES ${VALA_PACKAGES} glib-2.0)
set (VALA_PACKAGES ${VALA_PACKAGES} gobject-2.0)
set (VALA_PACKAGES ${VALA_PACKAGES} gtk+-3.0)
set (VALA_PACKAGES ${VALA_PACKAGES} keybinder-3.0)
set (VALA_PACKAGES ${VALA_PACKAGES} pango)
set (VALA_PACKAGES ${VALA_PACKAGES} pangocairo)
set (VALA_PACKAGES ${VALA_PACKAGES} vte-2.91)
set (VALA_PACKAGES ${VALA_PACKAGES} x11)
set (APP_SOURCES ${APP_SOURCES} ${CMAKE_CURRENT_BINARY_DIR}/Config.vala)
set (APP_SOURCES ${APP_SOURCES} PanedPercentage.vala)
......
......@@ -19,7 +19,7 @@
using Gtk;
using Gee;
//project version = 0.8.0
//project version = 0.8.1
namespace Terminus {
......
......@@ -13,24 +13,18 @@ custom: terminus_gnome_shell/metadata.json share/gnome-shell/extensions/showTerm
*vapidir: src/vapidir
vala_binary: src/terminus
*version: 0.8.0
*version: 0.8.1
use_gresource: extras_gresource_xml
vala_vapi: checkwayland.vapi
*vala_package: posix
*vala_check_package: atk
*vala_check_package: cairo
*vala_check_package: gdk-3.0
*vala_check_package: gdk-pixbuf-2.0
vala_check_package: gdk-3.0
vala_check_package: gtk+-3.0
*vala_check_package: gee-0.8
*vala_check_package: gio-2.0
*vala_check_package: glib-2.0
*vala_check_package: gobject-2.0
*vala_check_package: gtk+-3.0
*vala_check_package: keybinder-3.0
*vala_check_package: pango
*vala_check_package: pangocairo
*vala_check_package: vte-2.91
*vala_check_package: x11
*vala_source: PanedPercentage.vala
*vala_source: base.vala
*vala_source: bindkeys.vala
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment