25-from-2.15.1 1.51 KB
Newer Older
Radford Neal's avatar
Radford Neal committed
1
This mod incorporates features from R-2.15.1 and later R Core releases.
Radford Neal's avatar
Radford Neal committed
2 3 4 5 6 7

The "methods" package is now taken from 2.15.1, with a small 
mod for pqR.

The "utils" package is now taken from 2.15.1, with several
mods and additions for pqR.
Radford Neal's avatar
Radford Neal committed
8

9
Slight update to configure.ac from 2.15.1.
Radford Neal's avatar
Radford Neal committed
10 11

Now uses the share/texmf/tex/latex/jss.cls file from 3.1.1.
12 13 14 15

Now uses m4/java.m4 from 2.15.3.

Now uses m4/R.m4 from 2.15.3.  Supposedly fixes Objective C/C++ problem for Mac.
16 17

Now uses tools/config.guess and tools/config.sub from 3.1.1 (actually FSF).
18 19

Change to Makefile.in (deleting svn-vignettes) following 2.15.2.
20 21

Changes to graphapp, fixing a bug (from 2.15.2).
Radford Neal's avatar
Radford Neal committed
22 23 24 25

Take extra/tzone from 2.15.3.

Take extra/xdr from 3.1.1.
26 27

Updates to src/gnuwin32 taken from 2.15.1 and 3.0.0.
28 29 30

Added R_GetCurrentSrcref and R_GetSrcFilename from 2.15.1.

31
Added show.error.locations from 2.15.1.
32 33 34

The "tools" package is now taken from 2.15.1, with several mods
for pqR.
35 36

Take "datasets" package from 2.15.1.  Only one slight mod from 2.15.0.
Radford Neal's avatar
Radford Neal committed
37

38 39 40 41 42
Take "grDevices" package from 2.15.1.  This has the effect of doing
the following change from the 2.15.1 NEWS:

    colorRamp() (and hence colorRampPalette()) now also works for the
    boundary case of just one color when the ramp is flat.
Radford Neal's avatar
Radford Neal committed
43 44 45 46

Take "compiler" package from 2.15.1 (only slight changes from 2.15.0).

Change pmin/pmax for 0-length args, as in 2.15.1.
Radford Neal's avatar
Radford Neal committed
47 48 49

Change "exit" to "_Exit" in parallel package, similarly to
what is done in 3.1.1-patched.
Radford Neal's avatar
Radford Neal committed
50 51 52

Put in the mod from 2.15.3 to get plots to work with newer
versions of cairo.