Commit d76de924 authored by Oliver Smith's avatar Oliver Smith

Revert "ki18n: downgrade to 5.44 and pretend to be 5.45"

That didn't help either, although it did work on a test run on the
same PC that builds the real binary repository packages. Must be
a race condition, see #1458.
parent 0c7bf2ff
......@@ -2,8 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=ki18n
pkgver=5.45.0
_pkgver=5.44.0
pkgrel=2
pkgrel=3
pkgdesc='Advanced internationalization framework'
arch="all"
url='https://community.kde.org/Frameworks'
......@@ -11,12 +10,11 @@ license="LGPL-2.1"
depends=""
depends_dev="qt5-qtdeclarative-dev qt5-qtscript-dev"
makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
source="https://download.kde.org/stable/frameworks/${_pkgver%.*}/${pkgname}-${_pkgver}.tar.xz
pretend-to-be-5.45.0.patch"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz
fix-plasma-workspace-build-hanging.patch"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
options="!check"
builddir="$srcdir/ki18n-$_pkgver"
build() {
cmake \
-DCMAKE_BUILD_TYPE=Release \
......@@ -36,5 +34,5 @@ package() {
cd "$builddir"
make DESTDIR="${pkgdir}" install
}
sha512sums="92acb91807970f83182f35a3f356e8b9b70e7b3e1b07347ab4f16ef3200d5d95b6819218891b66bd43eee3efa5c17ee4c91c195ef1a05440b6dec7c34747ffa5 ki18n-5.44.0.tar.xz
8b1e53f302a4a8535d62ae124326e0756cb5c968f52a4a252e325aafba1c5f8dcc944ab1b895a3c444f0819efd604dee114fecbf8a547107c8cc2aa17c868bab pretend-to-be-5.45.0.patch"
sha512sums="3fde0c71d7ea65064c7a926c02b55ebe082cde673e581acbb24e7f614324de401e8d48ddbca0b15a59de3a8de9be867528124a328465e099b7bf07717fbeaa71 ki18n-5.45.0.tar.xz
29f6d8e62b7dac371cb2fe87f865304f14e38c330a46e61cabfbd1e7477f1d21c0fc0afadd6bc0892bbc798087fdf7b04239f2f3d9d1fc4508bc05424cdb714b fix-plasma-workspace-build-hanging.patch"
From f1bbc6993220921b30e59bf5091952c6400bf219 Mon Sep 17 00:00:00 2001
From: l10n daemon script <scripty@kde.org>
Date: Sat, 7 Apr 2018 07:47:38 +0000
Subject: [PATCH] GIT_SILENT Upgrade ECM and KF5 version requirements for
5.45.0 release.
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b018352..a8d8314 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,7 @@ project(KI18n VERSION ${KF5_VERSION})
# ECM setup
include(FeatureSummary)
-find_package(ECM 5.44.0 NO_MODULE)
+find_package(ECM 5.45.0 NO_MODULE)
set_package_properties(ECM PROPERTIES TYPE REQUIRED DESCRIPTION "Extra CMake Modules." URL "https://projects.kde.org/projects/kdesupport/extra-cmake-modules")
feature_summary(WHAT REQUIRED_PACKAGES_NOT_FOUND FATAL_ON_MISSING_REQUIRED_PACKAGES)
From 94acc129866640ab430dd462ea5c2678939d80d5 Mon Sep 17 00:00:00 2001
From: l10n daemon script <scripty@kde.org>
Date: Sat, 10 Mar 2018 08:40:07 +0000
Subject: [PATCH] GIT_SILENT Upgrade KF5 version to 5.45.0.
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f345ac2..4b4df4a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 3.0)
-set(KF5_VERSION "5.44.0") # handled by release scripts
+set(KF5_VERSION "5.45.0") # handled by release scripts
project(KI18n VERSION ${KF5_VERSION})
# ECM setup
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment