Commit 74c9fe72 authored by PureTryOut's avatar PureTryOut

kde/kimap: remove, upstreamed (!449)

parent 8f86bc76
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kimap
pkgver=18.12.3
pkgrel=1
pkgdesc="Job-based API for interacting with IMAP servers"
arch="all"
url="https://community.kde.org/KDE_PIM"
license="GPL-2.0 LGPL-2.0"
depends_dev="qt5-qtbase-dev kcoreaddons-dev ki18n-dev kio-dev kmime-dev cyrus-sasl-dev"
makedepends="$depends_dev extra-cmake-modules"
source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
subpackages="$pkgname-dev"
options="!check" # LoginJobTest fails (at least on QEMU aarch64)
build() {
cmake \
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
make
}
check() {
cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="73f3c7b790166606117421b40ba4f381d4455b08cf7bb9507297a68dac197b75dd16a2e4dc4b7eec5cb55c7743f5a9594a56190fc1d41e2ce1b3ed4ee3f99543 kimap-18.12.3.tar.xz"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment