Commit 455813de authored by Oliver Smith's avatar Oliver Smith

qt5-qtsensors: remove

It is in upstream now, and our version still was at QT 5.9 (which made
the upstream compatibility testcase fail).
parent eb709f24
diff --git a/src/compositor/extensions/qwlqtkey_p.h b/src/compositor/extensions/qwlqtkey_p.h
index fae02b0..d965eac 100644
--- a/src/compositor/extensions/qwlqtkey_p.h
+++ b/src/compositor/extensions/qwlqtkey_p.h
@@ -64,7 +64,7 @@ class QKeyEvent;
namespace QtWayland {
-class QtKeyExtensionGlobal : public QWaylandCompositorExtensionTemplate<QtKeyExtensionGlobal>, public QtWaylandServer::qt_key_extension
+class Q_WAYLAND_COMPOSITOR_EXPORT QtKeyExtensionGlobal : public QWaylandCompositorExtensionTemplate<QtKeyExtensionGlobal>, public QtWaylandServer::qt_key_extension
{
Q_OBJECT
public:
pkgname=qt5-qtsensors
pkgver=5.9.3
pkgrel=0
arch="all"
url='http://qt-project.org/'
license="GPL3 LGPL3 FDL custom"
pkgdesc='Provides APIs for sensors'
depends="qt5-qtbase"
makedepends="qt5-qtbase-dev"
source="http://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${pkgname/qt5-/}-opensource-src-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
builddir="$srcdir/${pkgname/qt5-/}-opensource-src-$pkgver"
build() {
cd "$builddir"
qmake-qt5
make
}
package() {
cd "$builddir"
make INSTALL_ROOT="$pkgdir" install
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "$pkgdir/usr/lib" -type f -name '*.prl' \
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
install -d "$pkgdir"/usr/share/licenses
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}
}
sha512sums="848184de2c914c0240f3ecffe96ab267fb24693d16a55c1c757d83af9f282bc6f6c5cd762cb42fc389bc02e301c21a6da7b178260f534db35f0abe277f638ea9 qtsensors-opensource-src-5.9.3.tar.xz"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment