Verified Commit 7fe039dd authored by Alexey Min's avatar Alexey Min 😑 Committed by clayton craft
Browse files

temp/gnome-software: break cyclic dependency with own plugin (MR 2879)

Depencency chain:

gnome-software -> gnome-softare-plugin-apk -> gnome-software-lib -> gnome-software

is broken.

Application should not depend on its own plugin,
instead plugin should probably be installed using
install_if="gnome-software apk-tools".

This is needed to unblock BPO:

master/x86_64/gnome-software-9999_git20211203-r0.apk (missing depends: gnome-software)

[ci:skip-build] already built successfully in CI
parent 0922ff0f
Pipeline #455503117 passed with stages
in 1 minute and 39 seconds
......@@ -2,13 +2,13 @@
pkgname=gnome-software
pkgver=9999_git20211203
_pkgver=41.3
pkgrel=0
pkgrel=1
pkgdesc="Software lets you install and update applications and system extensions"
url="https://wiki.gnome.org/Apps/Software"
# s390x, mips64 and riscv64 blocked by polkit
arch="all !s390x !mips64 !riscv64"
license="GPL-2.0-or-later"
depends="gnome-software-plugin-apk"
depends=""
makedepends="meson appstream-dev gdk-pixbuf-dev libxmlb-dev glib-dev gtk+3.0-dev
json-glib-dev libsoup-dev gnome-desktop-dev gspell-dev polkit-dev gtk-doc
ostree-dev flatpak-dev libgudev-dev gnome-online-accounts-dev libhandy1-dev"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment