Commit 5ff16dfe authored by Oliver Smith's avatar Oliver Smith

Update QT packages to QT 5.10 [skip ci]

Alpine's QT packages are at 5.10 as well, see #1458.
Building binary packages is going to take some time, I'm on it.
parent 471391af
# Forked from Alpine to use OpenGL ES2
pkgname=qt5-qtbase
_pkgname=${pkgname/qt5-//}-opensource-src
_pkgname=${pkgname/qt5-//}-everywhere-src
pkgver=9999
_pkgver=5.9.3
_pkgver=5.10.1
_ver=${_pkgver/_p/-}
_ver=${_ver/_/-}
_ver=${_ver/beta0/beta}
_ver=${_ver/rc0/rc}
_V=${_ver/rc/RC}
pkgrel=3
pkgrel=4
pkgdesc="Qt5 - QtBase components"
url="http://qt-project.org/"
arch="all"
license="LGPLv2 with exceptions or GPLv3 with exceptions"
license="LGPL-2.0 with exceptions or GPL-3.0 with exceptions"
_sub="$pkgname-sqlite $pkgname-odbc $pkgname-postgresql $pkgname-mysql
$pkgname-tds $pkgname-x11"
depends_dev="mesa-dev libice-dev libsm-dev libx11-dev libxext-dev
......@@ -36,7 +37,7 @@ makedepends="$depends_dev
libxrender-dev
libxslt-dev
libxv-dev
mariadb-dev
mariadb-connector-c-dev
mtdev-dev
pcre2-dev
postgresql-dev
......@@ -49,7 +50,7 @@ makedepends="$depends_dev
"
subpackages="$pkgname-dev $pkgname-doc $_sub"
case $pkgver in
case $_pkgver in
*_beta*|*_rc*) _rel=development_releases;;
*) _rel=official_releases;;
esac
......@@ -202,6 +203,6 @@ x11() {
return 0
}
sha512sums="256ffb8760e94c0f87790ed35e210d0c9613e14314ff442dd763cc93fbd5caa6c11c95f5d44b12a7687fb93c9f857878132cf6d76e5933f647ca7beb54b18c7c qtbase-opensource-src-5.9.3.tar.xz
sha512sums="abc8087bb7c5db2a668ba87cef67ab7ab9d884b770bce916b7fe7bf4e0a1fac47114eff50e15bd9efed66d63307d6aceed5cb097aa2ae5df98cffd11af8691ba qtbase-everywhere-src-5.10.1.tar.xz
7d68421a14f0259535c977d8a521c98918193c107b76ac664571b12f5b0d7588a0d0e1297af412a26753a393b21f3f44c3274fa8ab5bc87f03705a3a03acb444 qt-musl-iconv-no-bom.patch
95061cfb0924e26b123308c188c4bc5639d3f4d041dd48e5f8e399347d9b74278d0166e0889f32df112c0195d222ad024284830d6423b7061a32da0a7ebd04c5 libressl-compat.patch"
c23ceb261aeefdd1ba2b51a6487893b1a5d88e031646b06741e2f52f045bd0e387d1f9c033391bb187fedbb74add3e495909f9ebcc9da61617b21be33c597d57 libressl-compat.patch"
......@@ -8,3 +8,4 @@
+#if (OPENSSL_VERSION_NUMBER-0 >= 0x10002000L) && !defined(LIBRESSL_VERSION_NUMBER) && !defined(OPENSSL_NO_EC) && !defined(SSL_CTRL_SET_CURVES)
# error "OpenSSL was reported as >= 1.0.2 but is missing required features, possibly it's libressl which is unsupported"
#endif
--- qtbase/src/network/ssl/qsslellipticcurve_openssl.cpp 2017-01-18 15:20:58.000000000 +0100
+++ qtbase/src/network/ssl/qsslellipticcurve_openssl.cpp 2017-02-21 16:25:56.477986158 +0100
@@ -82,7 +82,7 @@
int nid = q_OBJ_sn2nid(curveNameLatin1.data());
-#if OPENSSL_VERSION_NUMBER >= 0x10002000L
+#if (OPENSSL_VERSION_NUMBER >= 0x10002000L) && !defined(LIBRESSL_VERSION_NUMBER)
if (nid == 0 && q_SSLeay() >= 0x10002000L)
nid = q_EC_curve_nist2nid(curveNameLatin1.data());
#endif // OPENSSL_VERSION_NUMBER >= 0x10002000L
--- qtbase/src/network/ssl/qsslsocket_openssl.cpp 2017-01-18 15:20:58.000000000 +0100
+++ qtbase/src/network/ssl/qsslsocket_openssl.cpp 2017-02-21 19:12:22.200604090 +0100
@@ -1626,7 +1626,7 @@
}
#endif // OPENSSL_VERSION_NUMBER >= 0x1000100fL ...
-#if OPENSSL_VERSION_NUMBER >= 0x10002000L
+#if (OPENSSL_VERSION_NUMBER >= 0x10002000L) && !defined(LIBRESSL_VERSION_NUMBER)
if (q_SSLeay() >= 0x10002000L && mode == QSslSocket::SslClientMode) {
EVP_PKEY *key;
if (q_SSL_get_server_tmp_key(ssl, &key))
--- qtbase/src/network/ssl/qsslsocket_openssl_symbols.cpp 2017-01-18 15:20:58.000000000 +0100
+++ qtbase/src/network/ssl/qsslsocket_openssl_symbols.cpp 2017-02-21 19:14:32.805677245 +0100
@@ -151,7 +151,7 @@
DEFINEFUNC(BIO_METHOD *, BIO_s_mem, void, DUMMYARG, return 0, return)
DEFINEFUNC3(int, BIO_write, BIO *a, a, const void *b, b, int c, c, return -1, return)
DEFINEFUNC(int, BN_num_bits, const BIGNUM *a, a, return 0, return)
-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
+#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
DEFINEFUNC2(int, BN_is_word, BIGNUM *a, a, BN_ULONG w, w, return 0, return)
#endif
DEFINEFUNC2(BN_ULONG, BN_mod_word, const BIGNUM *a, a, BN_ULONG w, w, return -1, return)
@@ -451,7 +451,7 @@
DEFINEFUNC(EC_KEY *, EC_KEY_new_by_curve_name, int nid, nid, return 0, return)
DEFINEFUNC(void, EC_KEY_free, EC_KEY *ecdh, ecdh, return, DUMMYARG)
DEFINEFUNC2(size_t, EC_get_builtin_curves, EC_builtin_curve * r, r, size_t nitems, nitems, return 0, return)
-#if OPENSSL_VERSION_NUMBER >= 0x10002000L
+#if (OPENSSL_VERSION_NUMBER >= 0x10002000L) && !defined(LIBRESSL_VERSION_NUMBER)
DEFINEFUNC(int, EC_curve_nist2nid, const char *name, name, return 0, return)
#endif // OPENSSL_VERSION_NUMBER >= 0x10002000L
#endif // OPENSSL_NO_EC
@@ -791,7 +791,7 @@
RESOLVEFUNC(EC_GROUP_get_degree)
--- ./config.tests/unix/openssl11/openssl.cpp.orig 2018-04-24 09:59:45.918038335 +0200
+++ ./config.tests/unix/openssl11/openssl.cpp 2018-04-24 10:01:21.255182441 +0200
@@ -42,6 +42,9 @@
#if !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER-0 < 0x10100000L
# error "OpenSSL >= 1.1 is required"
#endif
RESOLVEFUNC(BN_num_bits)
-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
+#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
RESOLVEFUNC(BN_is_word)
#endif
RESOLVEFUNC(BN_mod_word)
@@ -1020,7 +1020,7 @@
RESOLVEFUNC(EC_KEY_new_by_curve_name)
RESOLVEFUNC(EC_KEY_free)
RESOLVEFUNC(EC_get_builtin_curves)
-#if OPENSSL_VERSION_NUMBER >= 0x10002000L
+#if (OPENSSL_VERSION_NUMBER >= 0x10002000L) && !defined(LIBRESSL_VERSION_NUMBER)
if (q_SSLeay() >= 0x10002000L)
RESOLVEFUNC(EC_curve_nist2nid)
#endif // OPENSSL_VERSION_NUMBER >= 0x10002000L
--- qtbase/src/network/ssl/qsslsocket_openssl_symbols_p.h 2017-01-18 15:20:58.000000000 +0100
+++ qtbase/src/network/ssl/qsslsocket_openssl_symbols_p.h 2017-02-21 19:15:38.083714302 +0100
@@ -228,7 +228,7 @@
Q_AUTOTEST_EXPORT BIO_METHOD *q_BIO_s_mem();
+#ifdef LIBRESSL_VERSION_NUMBER
+# error "LibreSSL does not support all used OpenSSL-1.1 APIs yet."
+#endif
int main()
{
--- ./src/network/ssl/qsslsocket_openssl_symbols_p.h.orig 2018-04-24 10:40:49.121761681 +0200
+++ ./src/network/ssl/qsslsocket_openssl_symbols_p.h 2018-04-24 10:41:43.082843248 +0200
@@ -232,7 +232,7 @@ BIO *q_BIO_new_mem_buf(void *a, int b);
int q_BIO_read(BIO *a, void *b, int c);
Q_AUTOTEST_EXPORT int q_BIO_write(BIO *a, const void *b, int c);
int q_BN_num_bits(const BIGNUM *a);
-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
+#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
+#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
int q_BN_is_word(BIGNUM *a, BN_ULONG w);
#else
// BN_is_word is implemented purely as a
@@ -241,7 +241,7 @@
//
// Users are required to include <openssl/bn.h>.
#define q_BN_is_word BN_is_word
-#endif // OPENSSL_VERSION_NUMBER >= 0x10100000L
+#endif // (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
BN_ULONG q_BN_mod_word(const BIGNUM *a, BN_ULONG w);
#ifndef OPENSSL_NO_EC
const EC_GROUP* q_EC_KEY_get0_group(const EC_KEY* k);
@@ -509,13 +509,13 @@
// EC curves management
size_t q_EC_get_builtin_curves(EC_builtin_curve *r, size_t nitems);
-#if OPENSSL_VERSION_NUMBER >= 0x10002000L
+#if (OPENSSL_VERSION_NUMBER >= 0x10002000L) && !defined(LIBRESSL_VERSION_NUMBER)
int q_EC_curve_nist2nid(const char *name);
-#endif // OPENSSL_VERSION_NUMBER >= 0x10002000L
+#endif // (OPENSSL_VERSION_NUMBER >= 0x10002000L) && !defined(LIBRESSL_VERSION_NUMBER)
#endif // OPENSSL_NO_EC
-#if OPENSSL_VERSION_NUMBER >= 0x10002000L
+#if (OPENSSL_VERSION_NUMBER >= 0x10002000L) && !defined(LIBRESSL_VERSION_NUMBER)
#define q_SSL_get_server_tmp_key(ssl, key) q_SSL_ctrl((ssl), SSL_CTRL_GET_SERVER_TMP_KEY, 0, (char *)key)
-#endif // OPENSSL_VERSION_NUMBER >= 0x10002000L
+#endif // (OPENSSL_VERSION_NUMBER >= 0x10002000L) && !defined(LIBRESSL_VERSION_NUMBER)
// PKCS#12 support
int q_PKCS12_parse(PKCS12 *p12, const char *pass, EVP_PKEY **pkey, X509 **cert, STACK_OF(X509) **ca);
--- qtbase/src/network/ssl/qsslcontext_openssl.cpp 2017-01-18 15:20:58.000000000 +0100
+++ qtbase/src/network/ssl/qsslcontext_openssl.cpp 2017-02-21 19:23:04.291975945 +0100
@@ -344,7 +344,7 @@
const QVector<QSslEllipticCurve> qcurves = sslContext->sslConfiguration.ellipticCurves();
if (!qcurves.isEmpty()) {
-#if OPENSSL_VERSION_NUMBER >= 0x10002000L && !defined(OPENSSL_NO_EC)
+#if (OPENSSL_VERSION_NUMBER >= 0x10002000L) && !defined(OPENSSL_NO_EC) && !defined(LIBRESSL_VERSION_NUMBER)
// Set the curves to be used
if (q_SSLeay() >= 0x10002000L) {
// SSL_CTX_ctrl wants a non-const pointer as last argument,
@@ -462,7 +462,7 @@
m_npnContext.data = reinterpret_cast<unsigned char *>(m_supportedNPNVersions.data());
m_npnContext.len = m_supportedNPNVersions.count();
m_npnContext.status = QSslConfiguration::NextProtocolNegotiationNone;
-#if OPENSSL_VERSION_NUMBER >= 0x10002000L
+#if (OPENSSL_VERSION_NUMBER >= 0x10002000L) && !defined(LIBRESSL_VERSION_NUMBER)
if (q_SSLeay() >= 0x10002000L) {
// Callback's type has a parameter 'const unsigned char ** out'
// since it was introduced in 1.0.2. Internally, OpenSSL's own code
# Forked from Alpine to compile for armv7
pkgname=qt5-qtdeclarative
_pkgname=${pkgname/qt5-//}-opensource-src
_pkgname=${pkgname/qt5-//}-everywhere-src
pkgver=9999
_pkgver=5.9.3
_pkgver=5.10.1
_ver=${_pkgver/_p/-}
_ver=${_ver/_/-}
_ver=${_ver/beta0/beta}
_ver=${_ver/rc0/rc}
_V=${_ver/rc/RC}
pkgrel=0
pkgrel=1
pkgdesc="Qt5 - QtDeclarative component (#878: armhf is armv7)"
url="http://qt-project.org/"
arch="all"
......@@ -57,4 +58,4 @@ package() {
done
}
sha512sums="933caf5848437cde45b4bbf0c70b6cafbc690657c651508b28138b2f90d2f823f4842bc709f4726e2c88d3913a92240b0dcd9248d83af0d06d7127b9a8211b24 qtdeclarative-opensource-src-5.9.3.tar.xz"
sha512sums="b45b7c2232a3e7ddc8076066957f5c110a0ca9c815ee659f6e7656e85175a9ae56c52d6402d5437e4b60cd86508eb3c912ddd441e0be0ac9590ea263ad397048 qtdeclarative-everywhere-src-5.10.1.tar.xz"
# Contributor: Bart Ribbers <[email protected]>
# Maintainer: Bart Ribbers <[email protected]>
pkgname=qt5-qtvirtualkeyboard
pkgver=5.9.3
pkgver=5.10.1
pkgrel=0
arch="all"
url='http://qt-project.org/'
......@@ -10,10 +10,10 @@ pkgdesc='Virtual keyboard framework'
depends=""
depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtsvg-dev"
makedepends="$depends_dev hunspell-dev"
source="http://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/${pkgname/qt5-/}-opensource-src-$pkgver.tar.xz
source="http://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/${pkgname/qt5-/}-everywhere-src-$pkgver.tar.xz
0001-include-sys-time.h-for-timeval.patch"
subpackages="$pkgname-dev"
builddir="$srcdir/${pkgname/qt5-/}-opensource-src-$pkgver"
builddir="$srcdir/${pkgname/qt5-/}-everywhere-src-$pkgver"
options="!check"
build() {
......@@ -32,5 +32,5 @@ package() {
install -d "$pkgdir"/usr/share/licenses
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
}
sha512sums="feac25b2f88e182e58431a92e27436149072e2dd2eb09abbb69b732a6c3e484c4259759a99f730856993c6d50260bf5ef234f29f6f7e2a4fddbe77d15838b5c8 qtvirtualkeyboard-opensource-src-5.9.3.tar.xz
sha512sums="e317e19aa98bf5e5f8fed1ef03daec06ba2344be5b12021277d1f472b1cad809f7370dc45fc0d68f4a9ea91324b957aeae9db8513f7b894d2a7254acf62a8f76 qtvirtualkeyboard-everywhere-src-5.10.1.tar.xz
e801336b9aaf0facdcf7347fa8cf7223362312c92ea5725c5260d777045cc9da9a6de514dc4c17904aab77ae799bdd154c4615b8f2a39d92ce55ca10ad218efb 0001-include-sys-time.h-for-timeval.patch"
# Contributor: Bart Ribbers <[email protected]>
# Maintainer: Bart Ribbers <[email protected]>
pkgname=qt5-qtwayland
pkgver=5.9.3
pkgrel=1
pkgver=5.10.1
pkgrel=0
arch="all"
url='http://qt-project.org/'
license="GPL-3.0 GPL-2.0 LGPL-3.0"
......@@ -10,10 +10,10 @@ pkgdesc='Provides APIs for Wayland'
depends="qt5-qtdeclarative libxcomposite wayland qt5-qtquickcontrols2"
depends_dev="qt5-qtbase-dev"
makedepends="$depends_dev libxkbcommon-dev qt5-qtquickcontrols2-dev"
source="http://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${pkgname/qt5-/}-opensource-src-$pkgver.tar.xz
source="http://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${pkgname/qt5-/}-everywhere-src-$pkgver.tar.xz
0003-QtKeyExtensionGlobal-fix-export.patch"
subpackages="$pkgname-dev $pkgname-doc"
builddir="$srcdir/${pkgname/qt5-/}-opensource-src-$pkgver"
builddir="$srcdir/${pkgname/qt5-/}-everywhere-src-$pkgver"
options="!check"
build() {
......@@ -32,5 +32,5 @@ package() {
install -d "$pkgdir"/usr/share/licenses
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
}
sha512sums="1deb41d3a2e081fa434167211b975019840c56cbf04c8fc18325d405818c2ecee6d65c9376f498ddacc1587455d310b815d56124d6a7734b2857399abfb3b659 qtwayland-opensource-src-5.9.3.tar.xz
sha512sums="ca68abdc538c79a69776a55aa94c54db455536ab523e4b566f67fbdca7ee5a78f6eb95b52800425f79656dfe74ed06d5216be9d37babc833aacedeade7f4b2f3 qtwayland-everywhere-src-5.10.1.tar.xz
2e081b0bd66d4f3865a96a53df45fcd04f61a2a951be89ed46405b35a334b4900be1cd834b583c6dca4bfb75ed816aaab8a2d536962922505c30e48fdc3b394d 0003-QtKeyExtensionGlobal-fix-export.patch"
# Forked from Alpine to build against qt5-qtquickcontrols2
pkgname=qt5-qtwebchannel
_pkgname=${pkgname/qt5-//}-opensource-src
_pkgname=${pkgname/qt5-//}-everywhere-src
pkgver=9999
_pkgver=5.9.3
_pkgver=5.10.1
_ver=${_pkgver/_/-}
_ver=${_ver/beta0/beta}
_ver=${_ver/rc0/rc}
_V=${_ver/rc/RC}
pkgrel=0
pkgrel=1
pkgdesc="library for seamless integration of C++ +and QML applications with HTML/JavaScript clients."
url="http://qt-project.org/"
arch="all"
......@@ -40,4 +41,4 @@ package() {
cd "$builddir"/build
make INSTALL_ROOT="$pkgdir" install
}
sha512sums="d03a091121256532aac1ab4492b83ba29c847729f2628a2bc7a76b064d197e72cfdab50f0ec2314eac01cc47e2255bfef17f2e010d7b2c3d408b9af74c9ea136 qtwebchannel-opensource-src-5.9.3.tar.xz"
sha512sums="aea4c82d3873be24aa1648e197d6b3403f11658793dff40fe37cd3726a34360286638424cba83de530049e4ff5a69d9f251cb105c65da5142376dc2827510d47 qtwebchannel-everywhere-src-5.10.1.tar.xz"
pkgname=qt5-qtwebengine
pkgver=5.9.3
pkgver=5.10.1
pkgrel=0
arch="all"
url='http://qt-project.org/'
......@@ -7,8 +7,8 @@ license="GPL3 LGPL3 FDL custom"
pkgdesc='Provides communication between JS/HTML and Qt apps'
depends="qt5-qtbase qt5-qtquickcontrols2 python2 fontconfig dbus-x11 libcap libdrm libxcomposite libxcursor libxi libxrandr libxscrnsaver libxtst alsa-lib ffmpeg libwebp opus icu-libs libevent libexecinfo qt5-qtwebchannel libjpeg-turbo libintl gettext dbus libpbnjson luna-service2"
makedepends="qt5-qtbase-dev qt5-qtquickcontrols2-dev python2-dev bison flex gperf fontconfig-dev mesa-dev libcap-dev libdrm-dev libxcomposite-dev libxcursor-dev libxi-dev libxrandr-dev libxscrnsaver-dev libxtst-dev alsa-lib-dev ffmpeg-dev ffmpeg-libs jsoncpp-dev ninja libwebp-dev opus-dev icu-dev libevent-dev bsd-compat-headers libexecinfo-dev git qt5-qtwebchannel-dev libjpeg-turbo-dev gzip libintl gettext-dev yasm dbus-dev libpbnjson-dev luna-service2-dev binutils-gold"
builddir="$srcdir/${pkgname/qt5-/}-opensource-src-$pkgver"
source="http://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${pkgname/qt5-/}-opensource-src-$pkgver.tar.xz
builddir="$srcdir/${pkgname/qt5-/}-everywhere-src-$pkgver"
source="http://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${pkgname/qt5-/}-everywhere-src-$pkgver.tar.xz
patches-musl/0001-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch
patches-musl/0001-functions.prf-allow-build-for-linux-oe-g-platform.patch
patches-musl/0002-chromium-Force-host-toolchain-configuration.patch
......@@ -76,7 +76,7 @@ build() {
cd $srcdir/build
export QT_CONFIG=system-ffmpeg
qmake-qt5 CONFIG+="use_gold_linker" WEBENGINE_CONFIG+="use_system_ffmpeg use_gold_linker" "$srcdir"/${pkgname/qt5-/}-opensource-src-$pkgver
qmake-qt5 CONFIG+="use_gold_linker" WEBENGINE_CONFIG+="use_system_ffmpeg use_gold_linker" "$srcdir"/${pkgname/qt5-/}-everywhere-src-$pkgver
make
}
......@@ -92,7 +92,7 @@ package() {
install -d "$pkgdir"/usr/share/licenses
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}
}
sha512sums="0db532b4d54540da1ca63de1cc4d561d72f052211535f75f60b99c1858ec0819ab0f831a3326d58da6350066748634000fe7ad0719ca545e12f3ed249a6eb90a qtwebengine-opensource-src-5.9.3.tar.xz
sha512sums="dc1b15eb857cb9ff3ef98a2f90cfec8c40429eea292bbed6a323cf1c4b044f3b73efaf51833fe8d9ca2ecc4f99d7092590a1a34248a9ab14fa5a38d4335f4925 qtwebengine-everywhere-src-5.10.1.tar.xz
32648dcd9e389b52cf65f5085e72c35afe48a97285b549096cd6f561fdf39bb37372b464e9ebcba95611244b29fc76b63c76d805152edd2f2678d1a812429a50 0001-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch
18a1a30e9a5d7e67b1e94cfde1930685cbf80fb1e54c3c0fb5255ddf19cba6d9b8d5f1b681b1c755aa41111b2f1c05c8557caa11715b0506f6b3cdb9d7474423 0001-functions.prf-allow-build-for-linux-oe-g-platform.patch
351000898b7e5495dea555bd728d88be4c01e473892f001bf9cfe248fae443333be70778a309b20be3eb83b7bcd952d7fb62acfe0d61b01cf7e7dadfb8cc78ff 0002-chromium-Force-host-toolchain-configuration.patch
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment