Verified Commit 56f48ef2 authored by Paul Spooren's avatar Paul Spooren Committed by Oliver Smith
Browse files

main/postmarketos-ui-sway: add polkit-elogind dependency (MR 2677)



Without the explicit dependency to `polkit-elogind` the packages
`polkit` and `polkit-libs` are installed. This however prevents starting
`sway`. Below is the error message from the `tinydm` log:

```
00:00:00.028 [ERROR] [wlr] [libseat] [libseat/backend/logind.c:310] Could not activate session: Interactive authentication required.
00:00:00.028 [ERROR] [wlr] [libseat] [libseat/libseat.c:79] No backend was able to open a seat
00:00:00.028 [ERROR] [wlr] [backend/session/session.c:84] Unable to create seat: Function not implemented
00:00:00.028 [ERROR] [wlr] [backend/session/session.c:218] Failed to load session backend
00:00:00.028 [ERROR] [wlr] [backend/backend.c:353] Failed to start a DRM session
00:00:00.028 [ERROR] [sway/server.c:53] Unable to create backend
```
Signed-off-by: Paul Spooren's avatarPaul Spooren <mail@aparcar.org>
parent 72c2f02a
Pipeline #408629142 passed with stages
in 2 minutes and 43 seconds
......@@ -2,7 +2,7 @@
# Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
pkgname=postmarketos-ui-sway
pkgver=3
pkgrel=2
pkgrel=3
pkgdesc="(Wayland) Tiling WM, drop-in replacement for i3wm (DOES NOT RUN WITHOUT HW ACCELERATION!)"
url="https://postmarketos.org"
arch="noarch"
......@@ -12,6 +12,7 @@ depends="
dnsmasq
elogind
networkmanager
polkit-elogind
postmarketos-base-ui
pulseaudio
sway
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment