Verified Commit 02e0dfef authored by Oliver Smith's avatar Oliver Smith
Browse files

temp/epiphany: upgrade to 41.3 (MR 2792)

Fix current version of epiphany not being installable because of soname
bump in libportal:
  / # apk add epiphany
  ERROR: unable to select packages:
    so:libportal.so.0 (no such package):
      required by: epiphany-9999_git20210916-r0[so:libportal.so.0]

Upgrade to 41.3 while at it, and drop the firefox sync dialog patch
since it doesn't apply cleanly anymore. Only the disable fullscreen
patch is really important, Pablo only included the firefox sync patch
because it applied cleanly.
parent fad7c7ef
Pipeline #437391885 passed with stages
in 16 minutes and 59 seconds
From 69ab588d7f40aed43302d5f3a73fb7ab84be2b5a Mon Sep 17 00:00:00 2001
From: Patrick Griffis <pgriffis@igalia.com>
Date: Thu, 23 Dec 2021 14:51:50 -0600
Subject: [PATCH] Port to libportal 0.5
This was an API breaking release that requires minor changes.
Original patch:
https://gitlab.gnome.org/GNOME/epiphany/-/commit/84474398f6e59266b73170838219aa896729ce93
---
lib/ephy-flatpak-utils.c | 2 +-
meson.build | 2 +-
org.gnome.Epiphany.Canary.json.in | 6 ++++--
org.gnome.Epiphany.json | 6 ++++--
4 files changed, 10 insertions(+), 6 deletions(-)
diff --git a/lib/ephy-flatpak-utils.c b/lib/ephy-flatpak-utils.c
index 818af95f4..aef937f43 100644
--- a/lib/ephy-flatpak-utils.c
+++ b/lib/ephy-flatpak-utils.c
@@ -29,7 +29,7 @@
#include <gio/gio.h>
#include <gio/gunixfdlist.h>
#if USE_LIBPORTAL
-#include <libportal/portal-gtk3.h>
+#include <libportal-gtk3/portal-gtk3.h>
#endif
#include <string.h>
#include <sys/stat.h>
diff --git a/meson.build b/meson.build
index feb300b71..357035ee4 100644
--- a/meson.build
+++ b/meson.build
@@ -96,7 +96,7 @@ libhandy_dep = dependency('libhandy-1', version: '>= 1.1.0')
libsecret_dep = dependency('libsecret-1', version: '>= 0.19.0')
libxml_dep = dependency('libxml-2.0', version: '>= 2.6.12')
nettle_dep = dependency('nettle', version: nettle_requirement)
-portal_dep = dependency('libportal', version: '>= 0.0.2', required: get_option('libportal'))
+portal_dep = dependency('libportal-gtk3', version: '>= 0.5', required: get_option('libportal'))
sqlite3_dep = dependency('sqlite3', version: '>= 3.22')
if get_option('soup2').enabled()
diff --git a/org.gnome.Epiphany.Canary.json.in b/org.gnome.Epiphany.Canary.json.in
index bc6984838..09d479014 100644
--- a/org.gnome.Epiphany.Canary.json.in
+++ b/org.gnome.Epiphany.Canary.json.in
@@ -106,13 +106,15 @@
"name" : "libportal",
"buildsystem" : "meson",
"config-opts" : [
- "-Dgtk_doc=false"
+ "-Dbackends=gtk3",
+ "-Dintrospection=false",
+ "-Ddocs=false"
],
"sources" : [
{
"type" : "git",
"url" : "https://github.com/flatpak/libportal.git",
- "tag" : "0.4"
+ "tag" : "0.5"
}
]
},
diff --git a/org.gnome.Epiphany.json b/org.gnome.Epiphany.json
index 9f37ea823..5d2cb0d1a 100644
--- a/org.gnome.Epiphany.json
+++ b/org.gnome.Epiphany.json
@@ -103,13 +103,15 @@
"name" : "libportal",
"buildsystem" : "meson",
"config-opts" : [
- "-Dgtk_doc=false"
+ "-Dbackends=gtk3",
+ "-Dintrospection=false",
+ "-Ddocs=false"
],
"sources" : [
{
"type" : "git",
"url" : "https://github.com/flatpak/libportal.git",
- "tag" : "0.4"
+ "tag" : "0.5"
}
]
},
--
2.30.2
# Forked from Alpine to apply adaptability mobile patches
pkgname=epiphany
pkgver=9999_git20210916
_pkgver=41.0
pkgrel=0
pkgdesc="A simple, clean, beautiful view of the web"
_pkgver=41.3
pkgrel=1
pkgdesc="A simple, clean, beautiful view of the web [$_pkgver]"
url="https://wiki.gnome.org/Apps/Web"
# s390x, mips64 and riscv64 blocked by rust -> libhandy1
arch="all !s390x !mips64 !riscv64"
......@@ -22,7 +22,7 @@ _purism_patches="https://source.puri.sm/Librem5/debs/epiphany/-/raw/$_purism_com
source="https://download.gnome.org/sources/epiphany/${_pkgver%.*}/epiphany-$_pkgver.tar.xz
$_purism_patches/pureos/Disable-fullscreen.patch
$_purism_patches/pureos/firefox-sync-dialog-Use-GtkHeaderBar.patch
0001-Port-to-libportal-0.5.patch
"
builddir="$srcdir/$pkgname-$_pkgver"
......@@ -41,7 +41,7 @@ package() {
}
sha512sums="
3e3f8209238b0b7fb181c48899e815896a24aae5b318c2ca6a75ce334423290d006e138c63496a0bcd4f32846439426f46b84875b2306aabb5b87e53368f8118 epiphany-41.0.tar.xz
1effef22291687c8ff2252eced24274db3b1f4afacfc3053a33cae85112759918f80d824bb02b7e17d95364eec0062cb3459a6079783d9c900874cc150ea98ba epiphany-41.3.tar.xz
63290c9b52751e4adc324e5f39790ae809fe77067371c15e757e53244706e84063781e4ac9d38c892e0bf616c9dea0414157ba5db4c93a4523d291527603f56f Disable-fullscreen.patch
9d281bcdcc4263fb9302b381a9e2903b372ec83fd8a5fac85843a5cf45211d65d0a1b85272e0b80738e3268710fd361341e178fc06c6a2d643974114e836b14b firefox-sync-dialog-Use-GtkHeaderBar.patch
46b0c50c37ed5a10bb2bfdaffa8c2244eb34233e3446f08e8257340f60cee4797dd3dee37fb56005ddba1305b1708b14895983386a7d9ca0b868396aeda992ef 0001-Port-to-libportal-0.5.patch
"
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment