Commit 5a06b111 authored by Sandro Santilli's avatar Sandro Santilli

[run_test.pl] Do not assume OPT_UPGRADE_FROM was given

git-svn-id: http://svn.osgeo.org/postgis/trunk@16343 b70326c6-7e19-0410-871a-916f4a2858ee
parent 7d3e4f0e
Pipeline #16388702 passed with stage
in 21 minutes and 45 seconds
......@@ -1325,7 +1325,7 @@ sub prepare_spatial_extensions
if ( semver_lessthan($OPT_UPGRADE_FROM, "2.2.0") )
{
print "NOTICE: skipping SFCGAL extension create "
. "as not available in version $OPT_UPGRADE_FROM\n";
. "as not available in version '$OPT_UPGRADE_FROM'\n";
last;
}
$sql .= " VERSION '" . $OPT_UPGRADE_FROM . "'";
......@@ -1493,10 +1493,10 @@ sub upgrade_spatial_extensions
if ( $OPT_UPGRADE_FROM eq "unpackaged" ) {
$sql = "CREATE EXTENSION postgis_sfcgal VERSION '${nextver}' FROM unpackaged";
}
elsif ( semver_lessthan($OPT_UPGRADE_FROM, "2.2.0") )
elsif ( $OPT_UPGRADE_FROM && semver_lessthan($OPT_UPGRADE_FROM, "2.2.0") )
{
print "NOTICE: installing SFCGAL extension on upgrade "
. "as it was not available in version $OPT_UPGRADE_FROM\n";
. "as it was not available in version '$OPT_UPGRADE_FROM'\n";
$sql = "CREATE EXTENSION postgis_sfcgal VERSION '${nextver}'";
}
else
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment