Commit e7444cd4 authored by Ingemar Ceicer's avatar Ingemar Ceicer

AppImage and sort()

parent 84c622ae
......@@ -7,4 +7,4 @@ TryExec=hashsum
Exec=hashsum %F
Icon=hashsum
Categories=Utility;
X-AppImage-Version=91f32b6
X-AppImage-Version=84c622a
......@@ -7,7 +7,7 @@ linuxdeployqt hashsum -bundle-non-qt-libs -appimage -verbose=2 -qmake=/opt/Qt5.1
statisk
linuxdeployqt hashsum -bundle-non-qt-libs -appimage -verbose=2 -qmake=/opt/Qt5.14.1_static/bin/qmake -no-translations -no-copy-copyright-files -executable=hashsum -extra-plugins=platformthemes
linuxdeployqt hashsum -bundle-non-qt-libs -appimage -verbose=2 -qmake=/opt/Qt5.14.2_static/bin/qmake -no-translations -no-copy-copyright-files -executable=hashsum -extra-plugins=platformthemes
dynamisk ubuntu 16.04 32- bit
......
......@@ -2429,8 +2429,11 @@ bool Hash::askForFileNameCheck(const QString &sokvag2, const std::string &algori
}
}
qSort(fileNamesOld);
qSort(fileNamesNew);
// obsolete
// qSort(fileNamesOld);
// qSort(fileNamesNew);
fileNamesOld.sort();
fileNamesNew.sort();
QString no, nn, so, sn;
int pos1;
QList<QString>::iterator itOld;
......
......@@ -21,6 +21,7 @@
#include <string>
#include <sstream>
#include <fstream>
#include <algorithm>
#include "checkforupdates.h"
#include "config.h"
#include "extqlineedit.h"
......
......@@ -32,7 +32,7 @@ CONFIG += c++14
# GCC
TEMPLATE = app
TARGET = hashsum-2.5.0
TARGET = hashsum-2.5.1
#DEPENDPATH += .
#INCLUDEPATH += .
......@@ -40,17 +40,17 @@ TARGET = hashsum-2.5.0
# any feature of Qt which as been marked as deprecated (the exact warnings
# depend on your compiler). Please consult the documentation of the
# deprecated API in order to know how to port your code away from it.
#DEFINES += QT_DEPRECATED_WARNINGS
DEFINES += QT_NO_DEPRECATED_WARNINGS
# DEFINES += QT_DEPRECATED_WARNINGS
DEFINES += QT_NO_DEPRECATED_WARNINGS
## 32-bit Lubuntu 16.04
# CONFIG += /usr/lib/i386-linux-gnu/qt5/bin/lrelease embed_translations
## 64-bit Lubuntu 16.04
# CONFIG += /opt/Qt5.14.1_static/bin/lrelease embed_translations
CONFIG += /opt/Qt5.14.2_static/bin/lrelease embed_translations
# CONFIG += /opt/Qt5.13.1/5.13.1/gcc_64/bin/lrelease embed_translations
## Windows
# CONFIG += C:\Qt\Qt5.13.2_static\5.13.2\bin\lrelease embed_translations
CONFIG += C:\Qt\Qt5.14.2\5.14.2\bin\lrelease embed_translations
# CONFIG += C:\Qt\Qt5.14.2\5.14.2\bin\lrelease embed_translations
## 64-bit Lubuntu 14.04
# CONFIG += /opt/Qt5.8.0/5.8/gcc_64/bin\lrelease embed_translations
## Ubuntu 18.04
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment