...
 
Commits (3)
cache:
key: "$CI_JOB_NAME"
untracked: true
paths:
- node_modules/
before_script:
- npm install
.test_template: &npm_test
script:
- npm run lint
- npm test
test:node6:
image: node:6
<<: *npm_test
test:node8:
image: node:8
<<: *npm_test
test:node10:
image: node:10
<<: *npm_test
language: node_js
node_js:
- "7"
- "6"
script:
- npm run lint
- npm test
# Change log
## 0.1.4
### Other changes
* project: update dev dependencies (e0b36a9)
* project: migrate to gitlab (af3f598)
## 0.1.3
* fix: note minimum required node version (37e4481)
......
# hoopy
[![Package status](https://img.shields.io/npm/v/hoopy.svg?style=flat-square)](https://www.npmjs.com/package/hoopy)
[![Build status](https://img.shields.io/travis/philbooth/hoopy.svg?style=flat-square)](https://travis-ci.org/philbooth/hoopy)
[![License](https://img.shields.io/github/license/philbooth/hoopy.svg?style=flat-square)](https://opensource.org/licenses/MIT)
[![Build status](https://gitlab.com/philbooth/hoopy/badges/master/pipeline.svg)](https://gitlab.com/philbooth/hoopy/pipelines)
[![Package status](https://img.shields.io/npm/v/hoopy.svg)](https://www.npmjs.com/package/hoopy)
[![Downloads](https://img.shields.io/npm/dm/hoopy.svg)](https://www.npmjs.com/package/hoopy)
[![License](https://img.shields.io/npm/l/hoopy.svg)](https://opensource.org/licenses/MIT)
Like an array, but rounder.
......@@ -47,7 +49,7 @@ npm i hoopy --save
Or if you just want the git repo:
```
git clone [email protected]hub.com:philbooth/hoopy.git
git clone [email protected]lab.com:philbooth/hoopy.git
```
## How do I use it?
......
{
"name": "hoopy",
"version": "0.1.3",
"version": "0.1.4",
"license": "MIT",
"description": "Like an array, but rounder.",
"keywords": [
......@@ -24,16 +24,16 @@
},
"repository": {
"type": "git",
"url": "git+https://github.com/philbooth/hoopy.git"
"url": "git+https://gitlab.com/philbooth/hoopy.git"
},
"homepage": "https://github.com/philbooth/hoopy#readme",
"homepage": "https://gitlab.com/philbooth/hoopy#readme",
"bugs": {
"url": "https://github.com/philbooth/hoopy/issues"
"url": "https://gitlab.com/philbooth/hoopy/issues"
},
"devDependencies": {
"chai": "^3.5.0",
"chai": "^4.1.2",
"eslint": "^3.19.0",
"mocha": "^3.3.0",
"please-release-me": "^1.0.3"
"mocha": "^5.2.0",
"please-release-me": "^2.0.2"
}
}