Verified Commit b5e594a7 authored by Paul 🐻's avatar Paul 🐻

maintenance: upgrade ruvy and prepare for orgmode /o/

parent a79d8df1
Pipeline #23282344 passed with stages
in 3 minutes and 9 seconds
......@@ -19,5 +19,7 @@ gem 'font-awesome-middleman'
gem "middleman-disqus"
# Color syntax
gem "middleman-syntax"
# Org mode parser
gem "org-ruby"
gem "pry", group: :development
GEM
remote: https://rubygems.org/
specs:
activesupport (5.0.6)
activesupport (5.0.7)
concurrent-ruby (~> 1.0, >= 1.0.2)
i18n (~> 0.7)
i18n (>= 0.7, < 2)
minitest (~> 5.1)
tzinfo (~> 1.1)
addressable (2.5.2)
public_suffix (>= 2.0.2, < 4.0)
backports (3.11.1)
backports (3.11.3)
builder (3.2.3)
coderay (1.1.2)
coffee-script (2.4.1)
......@@ -19,16 +19,16 @@ GEM
sass (>= 3.2, < 3.5)
concurrent-ruby (1.0.5)
contracts (0.13.0)
dotenv (2.2.1)
dotenv (2.4.0)
em-websocket (0.5.1)
eventmachine (>= 0.12.9)
http_parser.rb (~> 0.6.0)
erubis (2.7.0)
eventmachine (1.2.5)
eventmachine (1.2.7)
execjs (2.7.0)
fast_blank (1.0.0)
fastimage (2.1.1)
ffi (1.9.23)
fastimage (2.1.3)
ffi (1.9.25)
font-awesome-middleman (4.2.1)
middleman-core (>= 3.0.0)
haml (5.0.4)
......@@ -39,7 +39,7 @@ GEM
hashie (3.5.7)
http_parser.rb (0.6.0)
i18n (0.7.0)
kramdown (1.16.2)
kramdown (1.17.0)
libv8 (3.16.14.19)
listen (3.0.8)
rb-fsevent (~> 0.9, >= 0.9.4)
......@@ -103,6 +103,8 @@ GEM
minitest (5.11.3)
nokogiri (1.8.2)
mini_portile2 (~> 2.3.0)
org-ruby (0.9.12)
rubypants (~> 0.2)
padrino-helpers (0.13.3.4)
i18n (~> 0.6, >= 0.6.7)
padrino-support (= 0.13.3.4)
......@@ -114,14 +116,15 @@ GEM
coderay (~> 1.1.0)
method_source (~> 0.9.0)
public_suffix (3.0.2)
rack (2.0.4)
rack-livereload (0.3.16)
rack (2.0.5)
rack-livereload (0.3.17)
rack
rb-fsevent (0.10.3)
rb-inotify (0.9.10)
ffi (>= 0.5.0, < 2)
ref (2.0.0)
rouge (2.2.1)
rubypants (0.7.0)
sass (3.4.25)
servolux (0.13.0)
sprockets (3.7.1)
......@@ -153,6 +156,7 @@ DEPENDENCIES
middleman-sprockets (~> 4.0.0.rc.1)
middleman-syntax
nokogiri
org-ruby
pry
BUNDLED WITH
......
......@@ -30,6 +30,7 @@ page '/*.txt', layout: false
# Renderers
###
require "lib/renderers.rb"
set :renderer, AnchorHeaderRenderer
###
# Helpers
......
require "middleman-core/renderers/kramdown"
class ::Middleman::Renderers::MiddlemanKramdownHTML
class AnchorHeaderRenderer < Middleman::Renderers::MiddlemanKramdownHTML
def convert_header(el, indent)
attr = el.attr.dup
if @options[:auto_ids] && !attr['id']
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment