CMake: Remove OggVorbis CMake module and use pkg_check_modules

We've long since moved from CMake 2.6 and require at least
CMake 3.0, which includes support for leveraging pkgconfig
modules. Let's use that for the Ogg Vorbis libraries.
parent e3db4dc8
Pipeline #11393073 passed with stage
in 3 minutes 39 seconds