Commit 08236f77 authored by Cristian Berner's avatar Cristian Berner 💎
Browse files

Fixes ISSUE-44832: Update postgresql driver to support scram password encrypt

Postgresql version >= 42.2.x is needed to support scram-sha-256 postgres
password encryption. This exists since postgres 11 and it requires
updating the client driver. Note, jre7 42.2.2 version didn't have this
feature included.

This updated driver also fixes several security issues and vulnerabilities.

Updated postgresql driver 42.2.2.jre7 -> 42.2.16
parent 87cfba58
......@@ -886,7 +886,7 @@ export.database: exports database structure and data to xml files.
<pathelement path="${base.lib}/runtime/log4j-core-2.11.1.jar" />
<pathelement path="${base.lib}/runtime/commons-pool-1.5.6.jar" />
<pathelement path="${base.lib}/runtime/commons-dbcp-1.4.jar" />
<pathelement path="${base.lib}/runtime/postgresql-42.2.2.jre7.jar" />
<pathelement path="${base.lib}/runtime/postgresql-42.2.16.jar" />
<pathelement path="${base.lib}/runtime/ojdbc8-19.3.0.0.jar" />
<pathelement path="${base.lib}/runtime/ant-1.9.2.jar" />
<pathelement path="${base.lib}/runtime/ant-launcher-1.9.2.jar" />
......
......@@ -114,7 +114,7 @@ Copyright (c) 2007, Yahoo! Inc. All rights reserved. Code licensed under the BSD
All files under Apache Software License 2.0, available at
http://www.apache.org/licenses/LICENSE-2.0
# postgresql-42.2.2.jre7.jar
# postgresql-42.2.16.jar
Under the BSD license, also available at http://jdbc.postgresql.org/license.html
# Dojo Foundation javascripts in web/js/dojo/
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment