Commit e05dc92d authored by Jorge Solórzano at OnGres's avatar Jorge Solórzano at OnGres 🐘

Update dependencies

parent 0d257f41
......@@ -21,15 +21,15 @@
<properties>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
<maven.minversion>3.5</maven.minversion>
<maven.compiler.minversion>11</maven.compiler.minversion>
<maven.minversion>3.6</maven.minversion>
<java.minversion>11</java.minversion>
<maven.compiler.release>11</maven.compiler.release>
<!-- Dependencies versions -->
<checkstyle.version>8.16</checkstyle.version>
<spotbugs.version>3.1.10</spotbugs.version>
<log4j2.version>2.11.1</log4j2.version>
<junit.version>5.3.2</junit.version>
<checkstyle.version>8.18</checkstyle.version>
<spotbugs.version>3.1.12</spotbugs.version>
<log4j2.version>2.11.2</log4j2.version>
<junit.version>5.4.0</junit.version>
<!-- Plugin versions -->
<compiler-plugin.version>3.8.0</compiler-plugin.version>
......@@ -40,17 +40,17 @@
<install-plugin.version>3.0.0-M1</install-plugin.version>
<resources-plugin.version>3.1.0</resources-plugin.version>
<dependency-plugin.version>3.1.1</dependency-plugin.version>
<javadoc-plugin.version>3.0.1</javadoc-plugin.version>
<javadoc-plugin.version>3.1.0</javadoc-plugin.version>
<checkstyle-plugin.version>3.0.0</checkstyle-plugin.version>
<enforcer-plugin.version>3.0.0-M2</enforcer-plugin.version>
<spotbugs-plugin.version>3.1.10</spotbugs-plugin.version>
<license-maven-plugin.version>1.17</license-maven-plugin.version>
<spotbugs-plugin.version>3.1.11</spotbugs-plugin.version>
<license-maven-plugin.version>1.19</license-maven-plugin.version>
<!-- Checkstyle properties -->
<checkstyle.config.location>com/ongres/checkstyle/checkstyle.xml</checkstyle.config.location>
<checkstyle.suppression.location>${project.build.directory}/build-resources/com/ongres/checkstyle/checkstyle-suppressions.xml</checkstyle.suppression.location>
<checkstyle.consoleOutput>true</checkstyle.consoleOutput>
<spotbugs.excluded.location>${project.build.directory}/build-resources/com/ongres/spotbugs/spotbugs-exclude.xml</spotbugs.excluded.location>
</properties>
......@@ -103,6 +103,12 @@
<groupId>com.github.spotbugs</groupId>
<artifactId>spotbugs-annotations</artifactId>
<scope>provided</scope>
<exclusions>
<exclusion>
<groupId>com.google.code.findbugs</groupId>
<artifactId>jsr305</artifactId>
</exclusion>
</exclusions>
</dependency>
</dependencies>
......@@ -119,14 +125,14 @@
</configuration>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-surefire-plugin</artifactId>
<version>${surefire-plugin.version}</version>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-surefire-plugin</artifactId>
<version>${surefire-plugin.version}</version>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-failsafe-plugin</artifactId>
<version>${failsafe-plugin.version}</version>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-failsafe-plugin</artifactId>
<version>${failsafe-plugin.version}</version>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment