Fix `helm upgrade` errors when running on Helm v3

Error: UPGRADE FAILED: cannot patch "gitlab-nginx-ingress-controller-metrics" with kind Service: Service "gitlab-nginx-ingress-controller-metrics" is invalid: spec.clusterIP: Invalid value: "": field is immutable && cannot patch "gitlab-nginx-ingress-controller" with kind Service: Service "gitlab-nginx-ingress-controller" is invalid: spec.clusterIP: Invalid value: "": field is immutable && cannot patch "gitlab-nginx-ingress-controller-stats" with kind Service: Service "gitlab-nginx-ingress-controller-stats" is invalid: spec.clusterIP: Invalid value: "": field is immutable && cannot patch "gitlab-nginx-ingress-default-backend" with kind Service: Service "gitlab-nginx-ingress-default-backend" is invalid: spec.clusterIP: Invalid value: "": field is immutable
2 jobs for master in 0 seconds (queued for 1459 minutes and 25 seconds)
latest
Status Job ID Name Coverage
  Prepare
failed #359261421
check_docs_lint

 
  Package
failed #359261422
lint_package

 
Name Stage Failure
failed
lint_package Package There has been a timeout failure or the job got stuck. Check your timeout limits or try again
No job log
failed
check_docs_lint Prepare There has been a timeout failure or the job got stuck. Check your timeout limits or try again
No job log