Commit fac38228 authored by Jakub Konečný's avatar Jakub Konečný

raised minimal version of PHP to 7.3

parent d90e7433
Pipeline #117973409 passed with stage
in 1 minute and 4 seconds
image: nexendrie/php:7.2
image: nexendrie/php:7.3
stages:
- test
......@@ -24,16 +24,6 @@ test:default:lowest-deps:
before_script:
- composer update --prefer-lowest --prefer-dist --no-progress --no-suggest --no-interaction
test:php7.3:
<<: *test_job
image: nexendrie/php:7.3
test:php7.3:lowest-deps:
<<: *test_job
image: nexendrie/php:7.3
before_script:
- composer update --prefer-lowest --prefer-dist --no-progress --no-suggest --no-interaction
test:php7.4:
<<: *test_job
image: nexendrie/php:7.4
......
......@@ -153,7 +153,7 @@ coding_style:
build:
environment:
php:
version: 7.2
version: 7.3
postgresql: false
redis: false
rabbitmq: false
......
language: php
php:
- '7.2'
- '7.3'
- '7.4'
- nightly
......
Version 0.7.0-dev
- dropped support for Nette 2.4
- raised minimal version of PHP to 7.3
Version 0.6.2
- allowed symfony/options-resolver 5
......
......@@ -19,7 +19,7 @@
"docs": "https://nexendrie.gitlab.io/site-generator"
},
"require": {
"php": ">=7.2.0",
"php": ">=7.3.0",
"ext-dom": "*",
"cebe/markdown": "^1.2",
"nette/finder": "^2.5.2 || ^3.0",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment