Commit 646ddd2a authored by Jakub Konečný's avatar Jakub Konečný

raised minimal version of PHP to 7.4

parent e25e5b2a
image: nexendrie/php:7.3
image: nexendrie/php:7.4
stages:
- test
......@@ -24,16 +24,6 @@ test:default:lowest-deps:
before_script:
- composer update --prefer-lowest --prefer-dist --no-progress --no-suggest --no-interaction
test:php7.4:
<<: *test_job
image: nexendrie/php:7.4
test:php7.4:lowest-deps:
<<: *test_job
image: nexendrie/php:7.4
before_script:
- composer update --prefer-lowest --prefer-dist --no-progress --no-suggest --no-interaction
test:cc:
<<: *test_job
script:
......
......@@ -153,7 +153,7 @@ coding_style:
build:
environment:
php:
version: 7.3
version: 7.4
postgresql: false
redis: false
rabbitmq: false
......
language: php
php:
- '7.3'
- '7.4'
- nightly
......
Version 2.3.0-dev
- raised minimal version of PHP to 7.4
Version 2.2.0
- raised minimal version of PHP to 7.3
- deprecated some getters and setters of BookControl and BookPage
......
......@@ -19,7 +19,7 @@
"docs": "https://nexendrie.gitlab.io/book-component"
},
"require": {
"php": ">=7.3.0",
"php": ">=7.4.0",
"nette/application": "^3.0",
"nette/utils": "^3.0",
"latte/latte": "^2.5 || ^3.0",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment