The primary idea is to prefix all vars with a common category
name while also renaming *some* main names.
Secondarily, add "`use_`" for all editable vars/ optional features
(example: `use_from, use_my_hdr`). Add "`_cmd`" suffix for all
external programs being called.
However, some existing vars already have a proper prefix matching their
category. In the case that some vars a properly prefixed (and others are
not), assume the prefixed ones will NOT get an additional prefix, there
will be only 1 prefix.
Example: "attach_split" won't become "attach_attach_split", even
though it isn't explicitly marked for a rename to "split" only, and then
again to be prefixed with "attach" for the whole
Add any missing vars.
* Integrate new vars in the "new" section from 1.5.15-1.5.19~tip.
* Add/integrate new vars >1.5.19~tip as they come out.
* For the above, create new sections as necessary and keep the version numbers up to date.
* Move variables around the sections if you find a better place.
* If you suggest a name change like "spoolfile" -> "inbox", then add* the new name in "()" after the original entry.