Remove Konacha and its configuration files

Signed-off-by: marcheing's avatarHeitor Reis <marcheing@gmail.com>
parent 66574bd0
......@@ -60,13 +60,6 @@ group :development, :test do
#Unit test framework
# This beta is tested against Rails 5. Once it gets released use the stable version.
gem 'rspec-rails', '>= 3.5.0.beta1'
#JavaScript testing
# Rails 5 requires a version higher than 4
gem 'konacha', '~> 4.0'
#Mocks and stubs for JavaScript tests
gem 'sinon-rails'
end
group :development do
......
......@@ -64,7 +64,6 @@ GEM
coffee-script-source
execjs
coffee-script-source (1.10.0)
colorize (0.7.7)
concurrent-ruby (1.0.2)
cucumber (2.3.3)
builder (>= 2.1.2)
......@@ -117,14 +116,6 @@ GEM
railties (>= 4.2.0)
thor (>= 0.14, < 2.0)
json (1.8.3)
konacha (4.0.0)
actionpack (>= 4.1, < 5)
capybara
colorize
railties (>= 4.1, < 5)
sprockets (>= 2, < 4)
sprockets-rails (>= 2, < 4)
tilt
libv8 (3.16.14.15)
listen (3.0.8)
rb-fsevent (~> 0.9, >= 0.9.4)
......@@ -221,8 +212,6 @@ GEM
json (~> 1.8)
simplecov-html (~> 0.10.0)
simplecov-html (0.10.0)
sinon-rails (1.15.0)
railties (>= 3.1)
spring (1.7.1)
spring-watcher-listen (2.0.0)
listen (>= 2.7, < 4.0)
......@@ -280,7 +269,6 @@ DEPENDENCIES
http_accept_language
jbuilder (~> 2.0)
jquery-rails
konacha (~> 4.0)
listen (~> 3.0.5)
poltergeist
puma (~> 3.0)
......@@ -289,7 +277,6 @@ DEPENDENCIES
sass-rails (~> 5.0)
shoulda-matchers (~> 3.1)
simplecov
sinon-rails
spring
spring-watcher-listen (~> 2.0.0)
sqlite3
......
Konacha.configure do |config|
require 'capybara/poltergeist'
config.spec_dir = 'spec/javascripts'
config.spec_matcher = /_spec\.|_test\./
config.stylesheets = %w(application)
config.driver = :poltergeist
end if defined?(Konacha)
namespace :konacha do
task :message do
puts "Running Konacha tests...\n"
end
end
task 'konacha:run' => 'konacha:message'
task :default => 'konacha:run'
#= require jquery
#= require sinon
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment