...
 
Commits (3)
......@@ -199,4 +199,11 @@ docs/output
docs/.doctrees
docs/generated
### Pycharm IDE ###
.idea
!.idea/vcs.xml
!.idea/modules.xml
!.idea/misc.xml
!.idea/workspace.xml
# End of https://www.gitignore.io/api/vim,macos,python,sublimetext,visualstudiocode
### Stage 1: Setup base python with requirements
FROM python:3.7-slim-stretch AS base-layer
COPY requirements/base.txt /tmp
# Add necessary packages to system
RUN apt-get update && apt-get install -y git && apt-get clean
RUN apt-get update && \
apt-get install -y git libmagic1 gcc && \
rm -rf /var/lib/apt/lists/* && \
apt-get clean && \
cd /tmp && \
pip install -r base.txt && \
apt-get autoremove -y --purge gcc
# Temp location: make sure we cache this bitch
RUN pip install ipython
# Copy requirements before copying complete source, to allow caching
COPY requirements/base.txt /tmp
RUN cd /tmp && pip install -r base.txt
# Set up application
COPY . /opt/minty_infra_amqp
WORKDIR /opt/minty_infra_amqp
......
......@@ -61,9 +61,9 @@ author = "Minty_infra_amqp Team"
# built documents.
#
# The short X.Y version.
version = "0.1.0"
version = "0.2.0"
# The full version, including alpha/beta/rc tags.
release = "0.1.0"
release = "0.2.0"
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
......
__version__ = "0.1.0"
__version__ = "0.2.0"
import threading
......
......@@ -12,7 +12,7 @@ sphinx-autodoc-typehints
bumpversion
## Framework
minty~=1.0.0
minty~=1.1.0
## Project specific requirements
......
[bumpversion]
current_version = 0.1.0
current_version = 0.2.0
commit = True
tag = True
message = "Tagged new version, from {current_version} to {new_version}"
......
......@@ -47,6 +47,6 @@ setup(
test_suite="tests",
tests_require=test_requirements,
url="https://gitlab.com/minty-python/minty-infra-amqp",
version="0.1.0",
version="0.2.0",
zip_safe=False,
)