fix: server/package.json to reduce vulnerabilities

The following vulnerabilities are fixed with an upgrade:
- https://snyk.io/vuln/SNYK-JS-MONGOOSE-472486
4 jobs for snyk-fix-fa7f1489b73cc49159a0e717c1193b6b in 5 minutes and 43 seconds (queued for 1 second)
latest
Status Name Job ID Coverage
  Test
passed test #322251337

00:05:43

 
  External
passed security/snyk - devops/devopsadmin/package.json (mindsphere)

00:00:00

passed security/snyk - package.json (mindsphere)

00:00:00

passed security/snyk - server/package.json (mindsphere)

00:00:01