Commit 1b5c2580 authored by Daniel Menelkir's avatar Daniel Menelkir

Added: plymouth-openrc-plugin (trunk)

parent 2f87b516
BDEPEND=>=dev-vcs/git-1.8.2.1[curl]
DEFINED_PHASES=install postinst unpack
DEPEND=sys-apps/openrc:=
DESCRIPTION=Plymouth plugin for OpenRC
EAPI=7
HOMEPAGE=https://github.com/aidecoe/plymouth-openrc-plugin
LICENSE=GPL-2+
PROPERTIES=live
RDEPEND=sys-apps/openrc:= sys-boot/plymouth
SLOT=0
_eclasses_=git-r3 562b380fc59ae6a8622171d0acb777d1
_md5_=26cdf442656533cedfc541465a8f47c5
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Plymouth plugin for OpenRC"
HOMEPAGE="https://github.com/aidecoe/plymouth-openrc-plugin"
inherit git-r3
EGIT_REPO_URI="https://github.com/aidecoe/plymouth-openrc-plugin.git"
SRC_URI=""
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS=""
IUSE=""
DEPEND="sys-apps/openrc:="
RDEPEND="${DEPEND}
sys-boot/plymouth"
src_install() {
insinto /$(get_libdir)/rc/plugins
doins plymouth.so
}
pkg_postinst() {
ewarn "You need to disable 'rc_interactive' feature in /etc/rc.conf to make"
ewarn "Plymouth work properly with OpenRC init system."
if has_version sys-apps/systemd; then
eerror "sys-apps/systemd is installed, please uninstall this package if you"
eerror "are booting with systemd"
fi
}
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment